Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R7 not working after firmware upgrade



I'm experiencing the exact same problem as well.  I recently upgraded to the latest firmware: 1.4.0 and had shot on my camera once, twice since then.  But then turning on my R7 this morning, and the camera did not function nor respond.  Here are the lenses I tried:

  • Canon RF 100-500 f4.5-7.1
  • Canon EF 70-200 f2.8L with Canon control ring mount EF-EOS R adapter
  • Canon EF 24-70 f2.8 with same Canon adapter ring mount
  • on all 3 lenses, made sure the switch was on AF (although I flipped back and forth to MF to see if there were any impact of this)

Yes, I tried reseting the camera.  Nothing changed.  Took out the battery (full charge) and put back in.  Nothing.

Yes, checked the AF/MF switch on the front of the camera.  Nothing.

In the AF menu, screen 1... only shows Manual Focus as the only option.



Do you perhaps have some custom setting enabled? Resetting of custom settings is often done as a separate action as compared to the general settings.

For the EOS R7, to reset other settings, see page 843 of the User Manual.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

I've tried resetting all the settings, even the custom ones, and still no functionality.  Since my last usage (when it worked) until this morning, there were no adjustments made to any customized settings.



Hello..  Canon?


Hi, dkangp!  We were going to let the Community continue to help you, but since you asked, you're welcome to call our EOS support team for guidance on this.  You can reach them at 1-800-OK-CANON (1-800-652-2666) and they're open weekdays from 9a to 9p ET (6a to 6p PT) and Saturdays from 9a to 7p ET (6a to 4p PT).  We look forward to your call!