Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R6 Mark II cannot see my WIFI but can see lot of others


01-Cameras can see a LOT of other Wifis, even some weird with empty names
02-Phones and computers can see MY wifi on 5G but NOT on 2.4
03-Cameras cannot see MY wifi nor 5G or 2.4 (but yes they can lot of others)
04-Mesh its working because I sent some photos, downloaded to phone, to the FTP using the mesh via phone
05-I set a 2.5 wifi with no security and no one was hable to see the wifi
06-Tried a 5g fully open with no password and phones and pc connectewd, but cammeras cant see
Been doing a lot of testing, and with even different cameras (cannon and Sony) they see a lot of networks but cannot see grandstream one.

Hope anyone can help



People from Grandstrem AP have been helping me, and we tried everyting, Since the camera is 5G compatible and the computers and phones can see the SSID in 5G they suspect it may be a firmware thing, thats the last thing we thought.

Hi Arcanebits,

If the camera can see other networks that indicates something about how your network is set up is preventing the camera from detecting it. Especially since the same thing is happening with multiple cameras from multiple manufacturers. There haven't been any firmware updates for the EOS R6 Mark II specifically for this kind of issue, but it could help if your camera is running an older firmware version.

The current firmware can be downloaded HERE. Once you are on the web page click on the Software & Drivers button and the current version is 1.3.0. Once the file is downloaded and extracted the instructions for doing the update are included in the file. Inside the extracted folder you will see the .fir file (which is the firmware update itself) and a folder with the update instructions.

When you are doing the update there are a couple of important things to do. One is that you should have a fully charged battery in the camera before starting the update. If the power goes off, or if a button is pressed that interrupts the update, it can cause the camera to stop functioning. If that happens the camera would need to be sent in for repair. The other thing is related to the .fir file. That is the only file you move to the memory card. You move it to the root folder of the memory card. In the root folder you will see a DCIM folder and a MISC folder. You would move the .fir file under those so that it shows up in the same section as those folders.



I've never heard of Grandstream, but am looking at their website now.  What is the model # of the APs you are using?

What encryption standard is your wireless network using? 

The camera supports Wi-Fi 5 (ac) standard and will connect to a 2.4 or 5G broadcast that uses WPA2 / AES encryption.  No firmware update is needed for the camera to connect, but you'll want the latest firmware for the fixes and enhancements it provides.  

I'm looking at the Grandstream documentation and website.  Wi-Fi 6/6e is (ax) make sure (ac) is also enabled for backwards compatibility.   Encryption should be WPA3 / WPA2 or WPA2 for backwards compatibility.   If set strictly to WPA3, the camera will not connect.  Also verify channel separation as older Wi-Fi uses 20/40/80mhz whereas 6/6e/7 uses 160/320.  

I recently upgraded to 6G mesh myself.  Went with Asus.  Not having the issues you are.  We only have 2 or 3 Wi-Fi 6 capable devices, but all of the 5G devices are performing well.  Your issue is definitely network settings related as Hazel_T pointed out.  You may need to "throttle" things back a bit to ensure older devices can connect and roam seamlessly.  Keep an eye out for updates from GrandStream too.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It