cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R6 Mark II GPS data not transferring to Canon Camera Connect app correctly

glewin
Contributor

i am using an EOS R6 Mk II and connect it to an iPhone 15 and the canon connect app to transfer GPS data, however I only seem to get the location of the first photo taken repeated across all of them.   I have tried many things and gone through all the settings but to no avail.   The phone GPS is fine as I also have photos taken on the phone at the same time and they have the correct locations.  Any suggestions please.

9 REPLIES 9

p4pictures
Whiz
Whiz

Have you viewed the GPS info on the camera for each of the photos. It could be that the camera and phone lost connection or stopped updating for some reason and so the camera used the last known GPS info for all the files.

When in playback on the camera, press the INFO button to show the display with the detailed info including the histogram, then move the multi controller down until the lower panel shows the GPS info.


Brian
EOS specialist trainer, photographer and author

I hadn’t done that Brian but have now and all the photos have exactly the same co-ordinates on them which clearly explains what I’m seeing but I have no idea why.   Presumably there is a communication glitch somewhere.

You do need to keep the Canon camera connect app open on the phone and allow it to get GPS info all the time if you haven't already done that.


Brian
EOS specialist trainer, photographer and author

I will have a play with it again.   I have allowed it free access but as I tend to put the phone back in my pocket until I want to use it then maybe the app goes to sleep.  Thanks for the info anyway. 

Thanks for this.  I obviously didn’t do a thorough search to see if this was a common issue.  

Mogster2k
Apprentice

I have exactly the same problem. R6ii and iPhone 15 also, both on latest versions of iOS and R6ii firmware. GPS data only updates when the app is re-started.

I’ve tried setting the location service to always, having the app on top and also set my phone to never lock (not that I want to wander around with an unlocked 1K iPhone…) Nothing makes any difference. The GPS icon is lit and the location info is transferred to the images but all the images have the same location and time stamp (UTC from GPS) as the first. Shoot time from the camera is applied correctly thankfully. When I view GPS infirmation in the menu tab the static information is there and the UTC. It’s interesting that in the GPS data in the menu UTC time isn’t updating but I’m not sure if it’s supposed to as that would require the camera to have an open connection to the phone constantly and the phone to be fulfilling the data request presumably.

I can only assume this is a bug in the app. Unfortunately the camera doesn’t recognize the location has chanced so happily applied the old position and UTC to all images.

Any help would be appreciated, although unless Canon are prepared to accept there’s an issue I can’t see this being fixed. It’s frustrating as this feature was a selling point for the camera, so I could move away from collecting GPS traces and applying locations afterwards.

Does anyone have this feature working correctly on recent version of the app and firmware?

I hadn’t realised that there has been an ongoing thread on this issue until I was sent the link in an earlier response.   T I have decided to give up and will have to bring my dedicated GPS unit out of retirement.  Haven’t used it on the R6 mk2 but I believe it does work 🤞

I have geotagged trips with file created from smartphone apps, it works but it’s a faff and another point of failure.

Id like to know exactly how Canons geotagging feature is supposed to work, and why this much advertised feature isn’t working. There isn’t a lot of information available about it, the manual is fairly sparse on this topic.

Announcements