Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 Connectivity Issue


Hi guys,


My EOS R5 cannot connect to any device (Macbook, iPhone, iPad) to transfer images.

When it is connected to Macbook the EOS Utility 3 does not recognize it. Even sometimes EOS Utility 3 recognized it the error occurs during starting transferring images.

When it is connected to the iPhone or iPad through Canon's Camera Connect app a similar error would occur during starting transfer images from R5 to the mobile device and the connection would be lost.


All the applications from Mac or iOS devices are updated to the latest version. My R5 worked yesterday. I have no clue what has been changed.

Now I cannot transfer any image from R5 to other devices using any application made by Canon. All the methods told by Canon's website have been applied in attempts of solving the issue. I can connect the R5 to my iPad Pro and import the images in the Photo app, which works perfectly.


Is there anyone having a similar issue?


Updates on 09-26 2020:


After quite a while since the post was created on 08-13 the issue persists. Bluetooth connectivity never worked. WIFI connectivity can be successful but unstable. The "target not found" error frequently happens in R5 when EOS utility is being used to transfer images and videos via WIFI connectivity between R5 and Macbook pro (Catalina 10.15.6). After not using the wireless connectivity feature for weeks it might work once with no issue when I tried. Once it worked with no issue for once it becomes unstable and unusable with errors.

The worst part of this issue is that Canon may not be able to reproduce the same issue on their end. Moreover, it is not persistent. I can only hope that Canon will eventually find out the defect they introduce in the software or hardware and fix it in the later framework update.


Upddates on 04-05 2021:


My issue was mainly the unusable conectivity with any type of connection between the EOS R5 and the computer/iPhone/iPad including USB-C cable, wifi and bluetooth.

The issue was significant while the USB-C cable was not working. I couldn't use any feature from the EOS utility like taking live shots from control of the computer or importing any photos/videos from the camera to computer/mobile devices. I had to use card readers to import my work every time. Later, I found that Imagin Capture or Google Photo app can actually detect the photos from the R5 via USB-C connection though Canon's EOS utility cannot detect the camera. The issue ws definitely only caused by the code in EOS Utility app of both Mac and iOS versions, not the USB-C connectivity.


The USB-C cable connectivity started working since the update of firmware 1.2.0. There was no clude how it was fixed for my camera as there is nothing mentioned in the update notes related to the connectivity issue. It magically started working with no issues in the use of all features of EOS utility.

Even nowadays I still haven't tried to use any wireless connectivity of R5. I don't have the confidence in the stability any more. Instead of wasting time to debug any protential issue I am just always using the USB-C cable for the connectivity.


Please report it to Canon tech support. If we can get more people complaining about it perhaps they could address it.

So I did send the issue to Canon Support. At first they said "send us your camera for repair".  I replied showing them this thread and said I think its bigger than my camera and is your firmware. They responded asking me to test it without my wifi on (I told them I live in a city so that does nothing).  They responded as follows:


Thank you for the response. Our engineers are researching a wifi issue on the EOS R5. Sometimes mesh wifi networks prevent the camera from connecting correctly. Since you are not the owner of the other networks in your area it is hard to say for sure if that is the cause here. Since the wifi works when you are out of the area it is likely what is happening. If that is the cause the current work around is to connect the camera and your smartphone through either Bluetooth or NFC. The mesh networks do not interfere with those connection types. At this time there has not been an announcement for when the issue will be resolved.


I added the empahsis above.

I have a 77d and it started doing this a year into having the camera, I tried everything to fix it without ripping the camera apart, complete reset was a no go. I have erro but it started happening before that if I remember right.

I find it hard to believe this wasn’t caught in any type of testing. I’ve done more client shoots in low density and high density destinations. It’s about a 50% percent change the Wi-Fi will be stuck in that mode. It will become an ever bigger issue with mesh networks becoming more popular.

In addition to this issue and after extensive amount of testing. I’ve concluded that the Wi-Fi always chooses to connect in 2.4Ghz mode with all my devices.

Tested devices: All have 802.11AC (5Ghz)
2015 MacBook Pro 15”
2018 MacBook Pro 15”
iPhone 12 Pro Max

After doing even more testing! I found that the R5 ONLY connects via 5Ghz if you manually choose the broadcast channel. Only channel 161 has reliably connected at the proper 5Ghz rate. CRAW files send over to my Mac in about 3-4 seconds compared to the 12-15 (2.4Ghz) second transfer times when doing the easy auto Wi-Fi setup. There’s no manual or documentation at all about this setting and I found it by sheer luck and curiosity.

Thanks for reporting!

Hello, chiming in. Yet another user with persistent Wifi  AND Bluetooth connectivity problems.


This is insanely annoying because it is a feature I was looking forward to experimenting with. We out here buying cars missing a wheel and these Canon folks are just ignoring us. It is now March and I have yet to hear a peep from them on any updates on the situation. Anyone got news on this? BTW I do not have one of those WIFI networks y'all were mentioning earlier.


It worked twice and haven't gotten it to work ever again.

I have the R5 brand new, and I share the main issue where we get stuck on "Search for access points" and the black square with the text that says "Searching..." (by doing wifi > connect to smartphone > add device > connect via wifi).


The one time it worked via just WiFi as above, it showed the same "searching" very quickly and then showed me a screen with WiFi name and password to connect to.
This seems like bad design because despite that it says "searching", it is supposed to be creating its' own network no?


By doing it the alternative Bluetooth way first, which magically connects the wifi for you after - is the only other way that worked for me the second time, and even that doesn't work anymore. At all.


I've also tried connecting to my laptop with all the appropriate software and latest everything installed (instead clicking connect to EOS Utility), and same issue. Just hangs on searching.

Also tried resetting connections and made sure firmware's updated.

The issue definitely is within the camera, hopefully firmware-fixable. This really sucks.

What device are you trying to connect to your R5 camera?


What, or which, Wi-Fi access point or hotspot are you trying to connect to?


Can you connect to this other device using Bluetooth?



"The right mouse button is your friend."

Hi Waddizzle


The issue happening is when creating an ad-hoc wi-fi network within the camera. It is not trying to join another wi-fi point.


I have been able to do a workaround and connect via Bluetooth, however, it is only a workaround to the main issue at hand- we can't create a wi-fi network in some locations. The locations that seem to prevent the camera from creating the network may be related to mesh wifi networks. At least the Eero mesh system.

Hi Wadd, the devices for me are an iPhone 11, an iPad Pro, and a MacBook Pro (only a couple years old).


I cannot answer the question about what I'm trying to connect to in terms of access point, because it does not let me get that far. When I attempt a connection it gets stuck on "searching" to no avail. It did work a couple times, and I have tried the bluetooth way which then does it for you, but that stopped working too after working once.


PS. in my experience it hasn't given me the option to connecto an AP, it has created its own CR5 access point when it worked.

Sad to report 1.3.0 is out (installed USA version just now) and the issue is still there (no mention of WiFi in the release notes). 


Everyone else, you got this issue, go report it to the real support line: strength in numbers. Just tell them the WiFi doesn't work with Eero Mesh Networks.


BTW I am using the real LP-E6NH that came with the camera, and this is for WiFi infrastructure mode (connect to your access point) and not peer-2-peer mode (connect camera to phone which works).

This issue is location based.

Even if you don’t have an offending and usually mesh (Eero) Wi-Fi network - your neighbor or a local business might have one and it will cause the R5 to stay in the “Searching for access points”

My work is architectural & interiors so I’m running into this issue quite often now. It’s not reasonable to ask the home owner to turn off an offending network or find a location where the signal isn’t causing the issue.

Once I’m home and I know for a fact no one around me has a mesh Wi-Fi network my camera works fine and starts up an ad-hoc network just fine.
Enter for a chance to win