Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 Connectivity Issue


Hi guys,


My EOS R5 cannot connect to any device (Macbook, iPhone, iPad) to transfer images.

When it is connected to Macbook the EOS Utility 3 does not recognize it. Even sometimes EOS Utility 3 recognized it the error occurs during starting transferring images.

When it is connected to the iPhone or iPad through Canon's Camera Connect app a similar error would occur during starting transfer images from R5 to the mobile device and the connection would be lost.


All the applications from Mac or iOS devices are updated to the latest version. My R5 worked yesterday. I have no clue what has been changed.

Now I cannot transfer any image from R5 to other devices using any application made by Canon. All the methods told by Canon's website have been applied in attempts of solving the issue. I can connect the R5 to my iPad Pro and import the images in the Photo app, which works perfectly.


Is there anyone having a similar issue?


Updates on 09-26 2020:


After quite a while since the post was created on 08-13 the issue persists. Bluetooth connectivity never worked. WIFI connectivity can be successful but unstable. The "target not found" error frequently happens in R5 when EOS utility is being used to transfer images and videos via WIFI connectivity between R5 and Macbook pro (Catalina 10.15.6). After not using the wireless connectivity feature for weeks it might work once with no issue when I tried. Once it worked with no issue for once it becomes unstable and unusable with errors.

The worst part of this issue is that Canon may not be able to reproduce the same issue on their end. Moreover, it is not persistent. I can only hope that Canon will eventually find out the defect they introduce in the software or hardware and fix it in the later framework update.


Upddates on 04-05 2021:


My issue was mainly the unusable conectivity with any type of connection between the EOS R5 and the computer/iPhone/iPad including USB-C cable, wifi and bluetooth.

The issue was significant while the USB-C cable was not working. I couldn't use any feature from the EOS utility like taking live shots from control of the computer or importing any photos/videos from the camera to computer/mobile devices. I had to use card readers to import my work every time. Later, I found that Imagin Capture or Google Photo app can actually detect the photos from the R5 via USB-C connection though Canon's EOS utility cannot detect the camera. The issue ws definitely only caused by the code in EOS Utility app of both Mac and iOS versions, not the USB-C connectivity.


The USB-C cable connectivity started working since the update of firmware 1.2.0. There was no clude how it was fixed for my camera as there is nothing mentioned in the update notes related to the connectivity issue. It magically started working with no issues in the use of all features of EOS utility.

Even nowadays I still haven't tried to use any wireless connectivity of R5. I don't have the confidence in the stability any more. Instead of wasting time to debug any protential issue I am just always using the USB-C cable for the connectivity.


Yes that is what is happening. If the camera happens to be in a wifi network it doesn’t like it will get stuck creating its own or searching for an access point. And I think a few of us may not have said it but for me at least my whole goal is to connect my Camera to Canon Connect on my iPad. Mine will work creating a bluetooth connection with Canon Connect.

I think I have discovered the cause of the issue.


I just bought two R5's that replaced the 5d IV's and 5DSR's I was using. 


I also ran into the issue where both cameras would not connect to any wifi networks and were stuck in the searching mode when I first tried to configure them, right out of the box.


By accident, I discoverd that if I used the real LP-E6NH batteries that came with the cameras, I was able to create ftp connections, connect to my Verizon Mifi, etc. just like with previous cameras.


As soon as I had an older "legacy" LP-E6N battery (or aftermarket battery) in the camera, it would be back in searching mode... and not even connect to my existing ftp networks I had set up.


Since discovering this, as long as I have the LP-E6NH batteries in the cameras, they connect flawlesly, and soon as I swap out and put other batteries in, it stops making network connections.


This is probably also why everyone who sent the camera into Canon got the message back from Canon  that the camera was working great... they were using the LP-E6NH battery to test it, so it worked fine.


That is also probably why people found sometimes it works, and sometimes it doesn't... it has everything to do with the battery, it appears. 


I am now connecting consistently as long as I am using the LP-E6NH. I hope this helps everyone who has experineced this... bummer that we have to buy more $80 batteries to get otherwise basic funtionality out of the camera. 




well,after countless attempts and calls to my local canon store i finaly found this post,,,,and guess what!!!!yes i changed the battery to the lp-e6nh and BINGO,,i have made the connection.thank you FRED sherlock holmes would be proud of your sluething the hell they get the camera to recognise a battery type?.as yo say,more inflated income for canon.thanks again Fred,stuart,UK.

My pleasure! I guess this hasn't solved everyones problems. but it made all the difference in making it work for me. Glad it helped you, too!

I've been following this thread and wanted to report that I think the new R6 1.4 firmware seems to have fixed this issue finally. When I first got my R6 I had the 1st generation Eero system and then moved to the Linksys Velop system. With both systems my R6 would get stuck searching for wifi. Today, after installing the new firmware, it appears to be working on my network finally. Hopefully someone else can report the same and that should mean the August R5 firmware will fix this issue for it as well. 

Adding for clarity that while the battery is likely not the issue, at least on the larger scale. I have been using exclusively the new batteries 100% of the time and the issue persists. Glad there's a new update though

This has been and continues to be a problem.  Canon is doing NOTHING to come up with a solution.  I was going to get a second R5 to replace and earlier EOS.  I am just going to hold off and perhaps looks for an alternative camera platform.

My issue was temporarily solved during a session with Canon support though we didn't make any change. Iy just started working and the support told the joke "because you called Canon".
My issue was later permanently resolved after applying the later firmware. No special mentions were in the update notes. It was probably cleaning some bad files or cache in the system and the issue was gone.

I applied the update and STILL CANNOT CONNECT with wi-fi.There has to be a BASIC design flaw in how wi-fi finds and connects to a local mesh network,  I do NOT have the problem with any other device other than the R5. 


It would be nice if we got an answer from Canon on how they propose to fix the problem. Or they should STOP advertizing that there is  wi-fi connectivity.

I noticed the same problem with my R6 and wifi, I do have a Mist Wifi network which consist of 3 AP, and you can tell from the selection screen that it shows all different AP SSID with the different channels as different networks.  The camera is most likely not being able to connect because of the way multiple AP are being advertised on the same SSID.   Many times I power on the camera and I get err64 , under the details when pressing the info utton it says "cannot connect to WLAN".  Usually I get it to connect by going under "switch network" then go through the prompts again and then on the next power on it will upload the images to cloud service.   I'm on firmware 1.2.0, have not tried 1.3.1 yet.  I will try calling canon support to report the issue.