cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R10 doesn't connect to smartphone

Uneternal
Contributor

I'm not sure if it worked before but yesterday I tried connecting my EOS R10 # to my Pixel 8 Pro and no matter which way I set it up, the phone doesn't connect to wifi. If I set up wifi directly, my phone doesn't connect saying I should check the password. I checked the password several times, even reset communication settings on the phone several times, and deleted the camera from the Canon app several times. Each time with the same result

When I use bluetooth the camera connects to the phone. But each time in the Canon app, as soon as I click on "Shoot" and the camera tries to setup a wifi connection, I get the following error:

Screenshot_20240221-123259.png

Useless to say, that waiting a little while did not fix the connection problems.
BTW I also own an EOS R and R5 and with both of them I got no problems. So this has to be a camera related problem.

1 ACCEPTED SOLUTION

Uneternal
Contributor

So meanwhile I got it fixed and just leave the solution here for anybody with the same problem. 
So after choosing "Connect via Wi-Fi" on the camera, you select "Switch network" > "Camera access point mode" > "Manual connection". Type your preferred name and in the next window choose manual setting again (leave the number at 1) > Encryption: None IP-Adress: Auto. 
Now, you get a wifi connection without a dumb password, and that fixed my connection problem.

View solution in original post

4 REPLIES 4

Uneternal
Contributor

So meanwhile I got it fixed and just leave the solution here for anybody with the same problem. 
So after choosing "Connect via Wi-Fi" on the camera, you select "Switch network" > "Camera access point mode" > "Manual connection". Type your preferred name and in the next window choose manual setting again (leave the number at 1) > Encryption: None IP-Adress: Auto. 
Now, you get a wifi connection without a dumb password, and that fixed my connection problem.

Uneternal,

Congratulations!

Thank you for posting your solution, so that others who have the same problem might learn how they can fix their problem too.

Steve Thomas.

This isn’t a ‘fix’ it’s a workaround. It’s something that still needs to be addressed. Disabling security is not the answer!

Thank you for calling this out.  I am only able to share my experience which has been favorable.  I use the default SSID and password generated by the camera.  I appear to be one of the few or the only user here who has successfully demonstrated Wi-Fi connection to my 6D2 and R5 C with a Pixel 6 & 8 100% of the time.  Android 13, Android 14, various security patches, Nov, Dec, Jan... and so forth.  It works for me.  I've tried to reproduce the behavior others describe and cannot.  My pixel devices will connect to any network I tell them to whether open or secured, with the SSID name, encryption type and password if it exists.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements