cancel
Showing results for 
Search instead for 
Did you mean: 

EOS M6 mark 1 buttons and touch screen suddenly not functioning

bluesbox01
New Contributor
Hello friends, need your help. My M6 mark 1 suddenly got this issue stated in the title. I did not drop it nor did it got wet. Anyone experienced it and how did you fix? Thank you.
4 REPLIES 4

Nick2020
Product Expert
Product Expert

Hi bluesbox01,

 

Thanks for checking in with us.

 

I suggest that you disconnect any accessories that we don't make then remove the battery and memory card and leave them both out for about five minutes. During this time I suggest that you check the camera to see if any buttons appear stuck or out of place. If so try to gently nudge them back into position.

 

It might also help to reset the camera settings, if you can get into the menu. In that case, navigate to the fourth wrench icon and then select RESET CAMERA.

Thank you for the reply!

 

After testing several scenarios, I pin-pointed the cause of the issue: camera stuck at focusing after either full or half click of the shutter button (indicated by the green color of focus box in the screen). I just soft press shutter button as temporary solution to "un-stuck" the button. I want to repair this myself. Would the alcohol method work for this issue?

Before you try the alcohol try sliding a piece of paper around the circumference of the button in the gap between the button and camera body. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

bluesbox01
New Contributor
Thanks for the input. I tried thoroughly moving a piece of paper back and forth in every angle of the gap between button and body but still the issue is there. Is it a broken mechanism that causes the camera to be stuck at focusing state?