cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 7D MkII Shutter Drive Issue

beerdog5
Apprentice

I have an EOS 7D Mark II that's having an issue while in One Shot mode.  When in full AE mode, the shutter operates properly with a single exposure.  When in any of the advanced modes, P, Tv, Av, I get a high-speed burst of exposures, even though it's in One Shot mode.

Any ideas?

1 ACCEPTED SOLUTION

kvbarkley
VIP
VIP

Do you have any exposure bracketing or HDR on?

Reset the camera to its defaults.

View solution in original post

6 REPLIES 6

kvbarkley
VIP
VIP

Do you have any exposure bracketing or HDR on?

Reset the camera to its defaults.

deebatman316
Authority
Authority

One Shot is a focus mode. It has nothing to do with how many pictures your camera takes. You need to look at what the Drive mode is set to. It sounds like Continuous High is set.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

beerdog5
Apprentice

Thanks for the quick responses...

Drive mode is definitely not set to continuous... it is set to single shot (whatever it's called).

I will look at exposure bracketing and HDR.  It's not just taking three shots, which is how I understood bracketing works, so I'm pretty sure it's not bracketing.  I may just go ahead and do a reset to see if that resolves it.

 

How many shots is the camera taking. The camera can be set to take more than 3 shots when bracketing.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

Waddizzle
Legend
Legend

Try resetting the camera back to factory defaults.

Drive mode controls how many shots are captured when the shutter button is fully pressed.  Other special operating modes can also capture multiple images with a single press of the shutter.

--------------------------------------------------------
"The right mouse button is your friend."

beerdog5
Apprentice

Thanks to all for the suggestions.  I don't recall setting it, but it turns out that HDR was set to Auto, and I was getting 3 shots at a time!  I disabled HDR and all is functioning properly now!  

Avatar
click here to view the press release
Announcements