cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 70D - Mode Dial problem...

patricio7707
Contributor

Hi ... I'm Patricio from Argentina.


One week ago I received from the U.S. a Canon EOS 70D.
It worked ok until yesterday.

 

Since today, when I want to choose different modes with the dial mode, the camera just sets: P or A+ (auto).

 

- If I select A+ mode (Auto mode) or "Disabling Flash mode" or "Manual mode" .... the camera sets as A+ (Auto mode).

- If I select modes: CA, SCN, C, B, AV, TV, or P ... the camera sets as "P mode".

 

I have read some similar cases in other models of EOS cameras ... they recommen do a "hard reset" by removing the main battery and clock battery.
I tried to do that, but this model (EOS 70D) seems to have a battery for the date and clock ... but it is internal, It`s a rechargeable battery.

 

I guess as a new model, there is no more than the actual firmware, that comes from factory ... so I can`t try to update, since there is no other firmware available.

 

Anyone have any suggestions before taking it for service?

Thanks!

 

you can see what's wrong with my 70D here: (the mode selected by the dial, it's not the same on the screen)

 

EOS 70D - Mode Dial Problem...

17 REPLIES 17

Yorptunes
Enthusiast

I took a look around the WEB and could only find one additional 70D user with the same problem.  The suggestion was to remove batteries OVERNIGHT to reset everything.  

 

I also have a 70D and checked mine and it is working as intended.  There are canon moderators that come on occasionally and assist with probelms like yours.  There are aslo some contributors with a many years of experience that may wade in on this issue.  Perhasp someone else can help before you have to take the camera back to canon for servicing.  

 

John  

TCampbell
Elite
Elite

Have you tried powering off the camera, removing the battery, waiting a minute, re-inserting the battery, and powering it back on?

 

The on/off switch is really puts the camera into an extended power-saving sleep mode.  The camera still technically has power.  When you turn on the camera again, the camera really just wakes up -- it does NOT actually re-start or reload the firmware.

 

If, however, you remove the batteries from the camera, you (mostly) deprive it of power.  When you insert the battery and power it up it actually forces the camera to load the stored firmware again... you are in effect "rebooting" the camera when you do this -- the camera does not "reboot" simply by turning the power swtich off and on again.

 

I did say "mostly" deprive power when you remove the battery because there is a technicality.  Depending on the camera body, most cameras have a 2nd battery used to store settings and also maintiain the date/time clock.  That battery is either a removable coin size battery OR it's a built-in rechrageable battery which recharges off the regular battery.  If you store the camera without a battery for too long, it will prompt you for the date & time when it powers up -- but this means the internal battery was depleted of power.

 

I *think* your 70D has an internal rechargeable battery.  Simply leaving the batteries out over-night will not be enough.  Hopefully just re-started the firmware by ejecting and re-inserting the main battery will be enough to fix the problem.

 

 

Tim Campbell
5D III, 5D IV, 60Da

I just turn on the camera after 24 hours since I removed the battery and memory card.

Nothing happened ... the problem persists. The camera din´t ask me to set the date and time... so I understand, the "internal battery" was not discharged.

Dear Patricio,
since yesterday i have nearly the same problem on my 70D. If i want to change to SCN it shows the previous modes correctly [Av -> M -> B -> C],  then switches to Av and then to the following modes [CA -> Flash of -> A+]. All other Modes work fine.

 

Do you still have the problem or could somebody help you?

 

Kind regards 

Daniel

I left my camera in the technical service and they determined it was a malfunction of the mode dial. They had to replace the "top cover".
Now I'm waiting for the camera, refurbished... Smiley Sad

sounds bad. I have the 70d for just 5 days now. Is it a know problem by canon?

Yesterday I reset all customizations before sending the camera back to the reseller. The last reset was "return to factory settings" reset. After the camera was resettet to factory settings the SCN Menu appeared as it should!
So I don’t know what leads to this problem, but at the moment the Mode Dial works correct.

Well, good for you!

 

The truth that what happened to me didn´t make me happy.
Right now I'm hoping Canon notify me when I go to pick up my camera.


Knowing that another had the same problem ... talk about a serious flaw in the design or behavior of the mode dial.
It would have been bad news for me ... because the piece replaced by Canon could fail again.


I hope it's permanent ... and my 70D perform as expected at the outset.

Hello,

 

Yesterday I get a problem with modes in my camera. 

 

Did someone helped and resolved your problems?

What did they do?

What would you advise me to do? I bougtht the camera in NY, but now I'm in Europe.

 

I have this camera now for 8 mounths, all worked fine till yesterday.

 

Avatar
click here to view the press release
Announcements