cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 60D SD Card Busy Light Stays on after every photo

zavoq
Contributor

I have found many posts about this issue but haven't been able to find a solution that works for me.  I have a 60D, has worked flawlessly for many years, but recently started having this issue. 

  • After shooting (nearly every photo) the SD card busy light stays on and the exposures remaining display flashes.  Pressing the play button displays a message on the LCD that simply says "Busy...Please wait."
  • Turning the power switch off when it's in this state extinguishes most of the other items on the LCD, but the exposures remaining counter still flashes and the busy light stays on.  The only way to get it to stop is to open the battery door to get it to shut off.

Here is what I have tried:

  • Waiting.  I have let the camera sit in the state for up to an hour, it never finishes whatever it is trying to do.  I assume if I wait until the battery completely depletes, it will power off but I haven't let it go that long.
  • New SD Card.  This happens on both of my existing 64GB Class 10 SanDisk Ultra cards, as well as a brand new 128GB SanDisk Extreme Pro (Class 10) card that I bought to trouble shoot this.  I even tried a small, low quality Kingston SD card.  Same behavior on all cards.
  • Low Level Formatting all cards.  Tried this, multiple times.  No joy.
  • Multiple Shooting modes.  Tried full auto as well as manual modes.  Same behavior in all modes.
  • Multiple lenses.  All yield the same result
  • Updated Camera Firmware.  Updated to ver. 1.1.2 (which is as far as I can tell the latest version Canon has published)

Anyone got any advice here?  Canon has unfortunately ended service for this model, so no help there.  Hoping I don't have a brick on my hands.

TIA.

14 REPLIES 14

rs-eos
Elite
Elite

Try resetting the camera back to factory defaults.  Perhaps you've enabled some feature that is leading to the higher write times.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Ricky,

Thanks for the suggestion.  I should have noted that I did also already try to reset the settings in the camera using the functions available in the on-camera menu.  Just for good measure, if just tried that again but unfortunately it did not have any effect.  Problem still present.

I did just find a mention of a small button backup battery and a teardown and replacement video on YouTube.  https://www.youtube.com/watch?v=vVZLdSoz1X4  Looks like a promising path that I may attempt next.

The internal battery only powers the clock circuit.  With a dead internal battery the camera would, barring some other problem, still turn on, only resulting in the clock having to be reset every time you turn on the camera.

That video is kind of vague about what he is doing, and no mention of what KIND of batteries he is trying. If it is not a rechargeable battery, he'd have to replace it when it wears out, just like a battery in a watch

Yeah, in that video he is trying to solve for a different issue than what I am having.  My camera powers on fine, I'm just looking for a way to completely power it down.  My working theory right now (weak as it may be) is that something is corrupted in the internal cache memory and that the only way to COMPLETLY factory rest it is to remove that battery.

Weak theory I know, but it's all I got right now.  Not in a hurry to disassemble it though, still hoping someone here has a better idea.

Waddizzle
Legend
Legend

Low Level Formatting all cards.  Tried this, multiple times.  No joy, “

What does that mean?  I cannot be certain.  Did the low level format fail?  Or did low level format not correct your issue?

A quick and dirty way to determine if you have a changed setting somewhere is to try switching the camera into fully automatic mode, the Green[A+] setting on the shooting mode dial.

Make sure that you only use full size SD cards.  Purchase them from a reputable dealer, preferably a Factory Authorized Canon dealer, not Amazon.  There are a whole lot of counterfeit camera accessories being sold on Amazon.  Some vendors do not even realize they have counterfeit stuff, but many of them do.

--------------------------------------------------------
"The right mouse button is your friend."

What I meant by that is that formatting the cards did not fix the issue.  The Low Level Format completes successfully, but the issue persists afterward.

All cards are reputable brand, full size cards.  The original 64GB Cards were the ones I have been using for at least the last 5+ years with no prior issues.  The new card I bought to test the "bad card/s" theory is also an authentic, full size SanDisk Extreme Pro card.  Three cards, all exhibiting the same issue seemed like enough evidence that the cards are not the issue, but just for good measure, I threw a Kingston card in just to change manufacturers.  Same issue with the Kingston card as well.  At this point I think it is highly unlikely that the SD card is the issue as the problem persists across 4 different cards.

Short of returning the camera to service, I'd have look and see if there is anything in the camera SD slot that might be blocking the contacts. Otherwise it could be possible that the camera SD slot has "worn out" and only makes inconsistent connections


Brian - Canon specialist trainer, author and photographer
https://www.p4pictures.com

Any suggestions on where to take it for service?  Canon's website makes it seem as though there is no service available for the 60D.

“ A quick and dirty way to determine if you have a changed setting somewhere is to try switching the camera into fully automatic mode, the Green[A+] setting on the shooting mode dial. “

Have you tried this, yet?  If not, I suggest that you do.  It only fakes a few seconds.

Invoking the menu selection to “restore factory defaults” does NOT fully reset the camera.  You would have to go through the menu system and reset at least a half dozen items to fully reset the camera.

--------------------------------------------------------
"The right mouse button is your friend."
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements