Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 5D Mark IV freezing up in self-timer mode


I am having a sudden issue using self-timer mode on my Canon EOS 5D Mark IV.

I was taking some family pictures & then was going to do a large group photo using self-timer.  I set it to 10 seconds, press down the shutter button to start the timer and then run into the photo before the timer ends.

I have done this process many times before!

Yesterday the shutter would not fire . . . at all! then the screen would freeze up completely.  I was not able to press the Q to access the screen or anything.  I was panicked and worried the camera is broke.  Through a quick google search I learned that it was due to being in self-timer mode.  I turned the camera off of self-timer and sure enough I was able to fire the shutter button again.

Why am I no longer able to use self-timer? 

Thank you!



What lenses, batteries and other accessories are you using on your camera. If they're 3rd Party remove them and retest with Canon equipment. 


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

I am using a sigma lens, but canon batteries.  I do not have a canon lens to use--but I have done this before (with the current equipment I have).

Has the camera been updated. I would also borrow a Canon EF lens. To rule out the Sigma lens potentially causing a problem now.


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

The camera has not been updated.

I will try with a canon lens!

I just tried with my 50mm lens (canon brand) and the same thing happened! 😞



Is the 2-second timer also misbehaving?

Steve Thomas

Yes!  I get the same response for either timer.

I just took some pictures of my husband & kids for father's day!  Works perfectly fine.  Tried the self timers again and it froze up!  So weird.


I'm not sure what to tell you. I don't see anything in the camera's menu system to tell you to Enable or Disable the self-timer.

Two things I might look at:

1) Have you tried a remote control accessory, and does the same thing happen?

2) If you are in One-Shot, the camera will not take a picture if it can't achieve focus. If you are in Servo mode, the camera will take a picture whether it's in focus or not.

Other than that, I can't think of anything.

Steve Thomas

I checked the focus.  It was in Servo so unfortunately that isn't the problem.  Thank you so much for your suggestions!!

I don't have a remote, but I will get one & try that

click here to view the gallery