Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 1v aperture won’t change


Recently I had an issue with autofocus while using my Canon 1v. I cleaned the contacts on lens and camera and it began working again. Same lens/camera setup - now autofocus is working but aperture is stuck at f/2.8. Put lens on other camera and everything is fine. Any easy fixes, and if not, what is process for getting a quote to fix? Thank you. 


Not applicable

It appears that Canon doesn't support that camera anymore. Midwest Camera Repair might be able to repair it.


Have you tried using all the different shooting modes? Program, Tv, Av, Manual? 

I would also try another lens on the EOS 1v.

When Canon discontinued the EOS 1v in 2018 it promised to service them until 2025.

According to Canon’s statement, it will repair existing EOS-1v units until October 31st, 2025, although repair requests may be denied after October 31st, 2020, depending on remaining parts and inventory.”



Mike Sowsun

Thank you, good information. I did use another kens and it worked fine but that was before the aperture problem. I’ll check. I also have only used  Manual mode. I’ll do more troubleshooting, thank you!

If you have only used Manual mode, make sure the Quick Control Dial Switch is set to ON. 
(we have all done it at least once)


Mike Sowsun

Oh my gosh. Smh. That was it. I was so nervous bc of the autofocus issue I had right before this. Thank you!

Enter for a chance to win