Showing results for 
Show  only  | Search instead for 
Did you mean: 

Corrupted CR2 File from EOS 5D Mark IV


Completed a shoot two days ago with around 400 exposures on my 5D IV.

I was shooting in RAW + JPG mode (I always have this enabled) and I thought I was shooting to both cards like I typically do (I wasn't).

When I got home Adobe LrC gave me an error that one file wasn't imported. I tried importing again and it still didn't work. I tried using Quicklook in Finder (Mac) and that didn't work. Tried opening in Adobe Ps, same error. Tried reimporting from the card thinking maybe it wasn't copied over properly, same error. Tried one more time to import from card but copied to the desktop and named it something different. Still wouldn't open.

Luckily the JPG version was normal so I used that and edited it as best I could. But this could have been really bad if it was one of the more important shots on a more important shoot, especially since I didn't have any indication of an error until I got home and tried to import.

Any ideas why this issue happens and how to prevent this issue going forward?

Edit: realized the other card actually WAS recording and dual-write was on in 5D IV (dual-write was off in my R6 and got the cards mixed up). So the other copy on the 5D IV SD card was fine. Redundancy win!



It happens, there is not much you can do except the built in redundancies of writing RAW+JPEG or to both cards.

In Syl Arena's Speedliter's Handbook he shows an example that happened to him, so it can happen to anybody.

Dang ok. That's not ideal but it makes sense that things fail - I've written thousands and thousands of files via this camera over the years.

I have so much redundancy in my system from hardware to software on the capture and backup sides and I guess this is an example for when two things go wrong (user error on dual card setting and corrupt RAW) I still was able to deliver a decent photo to the client... which is pretty good.

Thanks for your input. Will make sure to put dual write back on right now!

You might want to give Canon DPP a look, I have had files that Lightroom / Photoshop cannot work with and appear corrupt, but they do open in DPP. Then I have then been able to edit with DPP and get a 16-bit TIFF image that worked for me in my Lightroom workflow.

EOS specialist trainer, photographer and author

Oh very cool. I will look into this more. Seems like it could create a better workflow for me as well (current OG CamRanger user)


I don't have any solutions to offer, but I'm curious. Did the affected CR2 have a suspiciously smaller or larger file size than your other CR2 files? Was the affected file shot as part of a high frame rate burst? Maybe some early weakness showing up in a well used memory card . . ?

These are good questions, thanks for asking. No burst and the file was within range to the others. It was 41.1MB and the range on this shoot was between ~38-63MB at a quick glance.

Also: realized the other card actually WAS recording and dual-write on in 5D IV (dual-write was off in my R6 and got the cards mixed up). So the other copy was fine. Not sure what that means for troubleshooting though. I have used this CF card probably as long as I've had this camera.

The uncorrupted version is 50.7MB...


Note that as far as SD cards go, micro cards in an adapter are less reliable than full size cards. (Not that this is your issue, but I thought I would throw it out there.)

I agree. Adapters have always spooked me. Using all "correct" sized cards here. I do use card readers to import instead of a cable direct from camera to laptop so I guess that could be a point of weakness.