cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Computer won't detect camera

lyssa615
Apprentice

All of a sudden my computer won't detect my Rebel XT. I replaced the USB cord but nothing is even detected in "My Computer" or in the Device Manager. I am sure that the USB ports work properly as they work with other devices.  I reinstalled the software it came with and tried changing the communication settings on the camera. Does anyone have any suggestions? 

32 REPLIES 32

Jason
Whiz

Hello!

To ensure the most accurate information is provided, we will need to know the version of Windows you are using.

Thanks and have a great day!

Windows 7

xp

this usb cord worked before and works with other items... has to be something cannon has done... why does it all the sudden randomly quit working on a laptop that its been working on previously. wont install my camera....

Hi baileyka,

 

Just to confirm, are you using the EOS Digital Rebel XT like the user in the first post, or do you have a different model?

 

Thanks!

I have a Cannon Power Shot A 2300.  My computer was fine with it until yesterday and suddenly no longer recognizes it.  I have tried all the USB cords I have.  Any suggestions?

Hi SandyCurran,

 

Welcome to the Canon Community Forums! The PowerShot A2300 is a fairly recent model, so there shouldn't be any "incompatibility" issues. You mentioned it worked until yesterday, and that makes us wonder if maybe there were any recent updates to your computer, like Windows updates (or other program updates). Sometimes another program might update and cause unintended conflicts. 

 

Usually if that's the case, it's a pretty straight-forward fix, but it's something that would be to walk you through over the phone. We suggest reaching out to our 100% free, US-based team at 1-800-OK-CANON (800-652-2666) anytime between 10am and 10pm Eastern Time during the week (Monday through Friday), excluding holidays. 

I have a Canon 6d that will not read on my Macbook Pro when plugged in through the USB. It used to work a few weeks ago, but now it stopped working. I dont think anything has changed nor have I changed anything. The USB that came with the canon from original purchase has literally only been used once so It cant be the USB cord. I have researched everything and dont know what to do. Need some advice/suggestions/everything.

USB cords can be defective from the start, die after one use or a thousand.  The USB cord that came with my iPad worked once to charge the iPad, suffered no physcial trauma, but never worked again.  With an issue like this try a different port on your computer AND then a different cord.  You can also try connecting another USB device to your computer to see if it is recognized by that port.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video
Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.