cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Rebel t7 won't accept memory cards

mdrexl1
Apprentice

I have a canon rebel t7 (only a few months old), a fully charged battery, and a new 128 GB SanDisk memory card. 

I have 14 of these cameras (I am a teacher) and all of the other cameras work. I have tried resetting the camera back to factory settings. I have tried formatting the memory card (and using new ones). I keep getting the "Card cannot be accessed. Reinsert/change the card or format the card with the camera" message. 

The camera had been working previously and then one day would not take photos and keeps giving me the same message. Help! 

2 REPLIES 2

p4pictures
Rising Star
Rising Star

From your diagnostics and comparison with the other cameras it does sound like the card slot on the problem camera has an issue. I'd take a look and make sure nothing is stuck in the slot, but failing that it probably needs to be looked at by a service centre. 

 


Brian - Canon specialist trainer, author and photographer
https://www.p4pictures.com

deebatman316
Authority
Authority

Cameras such as the Rebel T7/ EOS 800D, XXXD lineup for some unknown reason. Do not work well with SDXC (64 GB) or larger SD Cards. They cause all sorts of errors and problems. Such as the camera hanging or locking up. The manual for the camera may say there compatible. They are NOT compatible. They'll work for a little while then stop. Stick with SDHC (32 GB) or smaller SD in this camera lineup. This is a very well documented problem in the forum.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D
Avatar
click here to view the press release
Announcements