Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 Freezing Up Intermittently


Anybody else having this problem with the Canon R6 freezing up. It usually starts with the camera not focusing. Its also becomes none responsive to mode changes. The on/off button doesnt work. Opening the battery door shuts it off... but still doesn't fix it. Pulling the battery out usually fixs the problem right away. But again... not always and sometimes it take a few battery removals to get it back up and running. 

This has happened while shooting both photo and video. It happens with different lenses. It happens with different memory cards. I can't recreate the problem on command. The camera works 99% of the time. But at least once a wedding shoot, over the period of 6 hours, It freezes up!

In the video below... I was attached to the Ronin gimbal. But it's happened just shooting photos and without the gimbal. Plus, when I open the battery door and try and turn the camera on/off... it still doesn't work. Has nothing to do with that.

I was on firmware version 1.4
I updated the firmware this week to version 1.5.0.
This problem has been happening for a long time... 8 months. Camera is less than a year old.

Again, at last nights wedding... it froze. 

Here is a video that I recorded when it happened.
1. Focus isn't working. Both back button and touch.
2. Display freezes up. You can still see the audio working.

3. On/off doesn't work.

4. open battery door... nothing works.

5. Pull Battery

145 REPLIES 145

I am sorry to hear that you had to pay for something that clearly should be free, on top of paying for the shipping. Is yours no longer freezing up? How is the repair holding up? Anyway, the more people that writes here, the more data I get for the attorneys. I am gauging the response. 

Repairs seem to be doing okay so far. I sent them I believe in January. 

Same here!  New motherboard for r6.  Sounds like a big prob.  Mine in warranty - never really  worked 

I sent mine in today. I’m spending over $500 with shipping to pay to repair my R6 purchased in Feb 2022.  I hope Canon makes this right.

I am lucky that in NZ our Canon cameras come with a standard 5-year warranty, and so far (touch wood) in 40 years of shooting with them, I have never had a Canon camera fail.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Sending is not going to help IMHO. I had my camera replaced about a year since I bought it and faced problems. The replacement has exactly the same issue.


I'm probably going to have to send my R6 in too.   I've tried everything including upgrading to latest firmware.  I also have an R5 which works flawlessly.  Anytime I shoot Video on the R6 the camera locks up after a short time and the only way to recover is to remove the battery.  


Still happening on my camera. I was in Tanzania for 7 days and experienced it 3 times. 

Solution it to remove the batteries and restart. It seems this is a hardware issue that Canon is not acknowledging. Even after several firmware updates this issue is not solved. Canon does not want to replace the hardware from the users.

Has this been resolved in Mark ii?


It's hard to dispute there is a problem. Especially when posting the video that has over 1000 views and nobody says anything.

On a compltely different side note, I've declared my R5 useless as I mainly shoot weddings. And the error 20 comes up about once an hour. Today 30 popped up. 30 is new... but it's just over a year since I bought it. I can't depend on it for a wedding shoot. I recently lost a ceremony kiss because of this error 20.

Sending it in. Estimate is $500usd to take a look and hopefully fix it! Arrrrrg.

On another side note... my R6 Mark II seems to be working correctly. Yeah Canon.... that's 1 out of 5 of my new mirrorless cameras I can't complain about. haha (3 R6's, 1 R6 MII, and 1 R5)


Make sure that you have wireless communications disabled.  Enable airplane mode.

Also, if you are using third party lenses and/or mount adapters, then that could be the problem.

"The right mouse button is your friend."
click here to view the gallery