Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 Freezing Up Intermittently


Anybody else having this problem with the Canon R6 freezing up. It usually starts with the camera not focusing. Its also becomes none responsive to mode changes. The on/off button doesnt work. Opening the battery door shuts it off... but still doesn't fix it. Pulling the battery out usually fixs the problem right away. But again... not always and sometimes it take a few battery removals to get it back up and running. 

This has happened while shooting both photo and video. It happens with different lenses. It happens with different memory cards. I can't recreate the problem on command. The camera works 99% of the time. But at least once a wedding shoot, over the period of 6 hours, It freezes up!

In the video below... I was attached to the Ronin gimbal. But it's happened just shooting photos and without the gimbal. Plus, when I open the battery door and try and turn the camera on/off... it still doesn't work. Has nothing to do with that.

I was on firmware version 1.4
I updated the firmware this week to version 1.5.0.
This problem has been happening for a long time... 8 months. Camera is less than a year old.

Again, at last nights wedding... it froze. 

Here is a video that I recorded when it happened.
1. Focus isn't working. Both back button and touch.
2. Display freezes up. You can still see the audio working.

3. On/off doesn't work.

4. open battery door... nothing works.

5. Pull Battery

128 REPLIES 128

I've experienced this issue quite a  few times. My firmware is the latest 1.6.0. My solution  is to take the battery out and put it back again and it will fix the issue. I didn't realize there are so many people have the same issue until I came across this community, and  Canon still hasn't found the root cause? I don't think it should be so picky with batteries (mine is original battery)or cards. It's definitely a bug or flaw.


Again, same problem.  I have the latest firmware and canon replaced my main board.


The current firmware version is 1.6.0.   It will contain the previous cumulative updates.

You can find the firmware update page HERE .

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Took my R6 800mm f/11 1.4x out the other day. Firmware was the previous version before 1.6. Used to freeze up occasionally. Photographing a Bald Eagle perched in tree. Single AF point, shutter 1/500. Changed EV to something like +2 because the Eagle was backlighted against a bright sky. Froze up every other shot. Had to remove the battery. Try again. It was the worst experience. Every time I tried raising the EV value it froze taking a few shots. Tried saving the raised EV setting in C2. When the camera froze again, battery out, the saved C2 settings were lost as well. Was shooting with two SD cards formatted low level in the camera. Warranty expired around December/January during peak bald Eagle shooting time, so sending it in for motherboard replacement wasn’t an option. Placed my hopes on the reported firmware updates. After the last outing, loosing my faith in Canon Cameras. Just applied firmware update 1.6. Will try again. I’ve owned five Canon cameras over the years. Had good experiences with all of them, even with the Canon 90D and it’s soft focus, missed shots issues. The Canon R6 was the best of the lot, especially it’s animal / eye tracking. Loved it, except for the occasional, infrequent freezes. Again last outing was the worst, ever. Thought the newer Canon battery, newly charged, could be the issue, so I put in the battery that came with the 90D. Will have to try again. Been shooting hummingbirds all summer with two memory cards with no issues. Curious, the correlation between changing the EV and camera freezes.

I am pretty consistent with doing firmware updates and have the updated version and have even worse issues than before including entire sequences of images just simply not writing to the card because the system freezes & errors out. Assuming people are just simply not following instruction isn't actually a helpful resolution. 


Have been experiencing a lot of freezes - black monitor in viewfinder and / or lens error. Turning the camera of does not help. Taking the battery out does and everything gets back to normal.

I figure it's the servo / instant auto focus that confuses the camera / lens when it's hanging upside down on my hip (using a slide strap mounted to the bottom of the cam), but it's just a hunch.


could be a dji gimbal issue if it's plugged in? 

Couldn’t agree more!  Same issue and have tried all the suggested solutions.  This is happening to too many people for it to be a “not every camera is perfect out of the box” problem 


I will repeat the comment that I posted prior to the comments by two others (who by the way should be posting their own threads - it gets very confusing dealing with multiple contributors) who may have different characteristics in their configuration and use of the cameras. 

It is very important to keep the firmware up to date!  The current version is 1.6.0 and that is the last in a series past 1.50.0 - that series included 1.5.1 and 1.5.2 - both of which included significant updates to focusing.  So, if those of you having issues have not updated to FW version 1.6.0 you need to do so.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

My firmware is up to date, I use RF lenses, I use 18gb SanDisk Extreme PRO 170MB/s and it still happens