Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R5 freeze after 1.5.1 update


Hi Canon,

After installing firmware 1.5, I was having my R5 freeze regularly with animal eye autofocus mapped to back button focus. I installed firmware update 1.5.1 this weekend hoping it will fix the issue. I went out today to shooting some shore birds. My R5 locked up 3 times in a period of 1.5 hours of shooting, one of the three was was with error E70. In all three cases, turning the camera off/on fixed the issue; this is different from firmware 1.5 freezes, where I had to take out the battery to fix the freeze. 

Please let me know if you need more information about the camera settings. I happy to share them. 

Regards, Mo


I scrolled to the top of this thread. That user reported an "Error 70". I'm not getting an error message. It just freezes and I have to turn it off, remove the battery. Only twice did any kind of message appear - it told me to shut down and remove the battery, which I had already figured out on my own.

I don't see anything from you in reply to that message that says anything other than removing the battery and changing the memory card. Since removing the battery does not permanently fix the issue, and since it happens with either memory card, and since I always start with a formatted card, none of those things resolve the issue. Is there some other instructions in a prior thread to which you are referring?


Hi Hazel, 

This morning, I low-level formatted a different card from a different manufacture, a 128GB Sandisk, in camera. Tried to focus on a nearby roof -- about 50 meters away. The camera locked up within the first 15 seconds of keeping the back button focus pressed.

Regards, Mo 

Thanks Joseph, 

I actually sent the camera and lens to Canon repair (I have CPS membership) two times already over the last month for inspection/repair; in both cases they returned them with a note that they operating within  spec, and a future firmware will fix the problem, this was before 1.5.1 was released. I saved the settings that I replicate the problem with in case Canon need them. 

Regards, Mo


I would like to add to this thread since I am having similar problems after the 1.5.1 update. I plan to continue gathering information and will contact Canon again. 

1. I am using the R5 with the AF-On button set to center point Servo. The star button is set to Animal Eye detect. The shutter button has no focus function, just takes the photo.  
2. I am using a ProGrade card 128 GB, 300 MB/s R, 250MB W
3. I am using the RF 100-500 lens with the RF 1.4x attached. Prior to installing version 1.5 and then later 1.5.1 I never had issues with the 100-500 causing a freeze. I only had updated to 1.2 and no further. However, I did not have the 1.4x extender at that time. I just began using the extender with version 1.5. 
4. Camera froze about 5 times with 100-500 in 15 min. after 1.5.1 update. It was freezing with 1.5 also.   I was going back and forth between AF-On button and * button. 
5. I called Canon and was ready to send the camera in, but rep told me to try it without the 1.4x attached. I did and went out and took approximately 400 shots with no issue. I went back and forth between the two buttons and all worked very well. 
6. I also tested the 1.5.1 update with the 600 mm f11. Again, no issues and I photographed like I normally do going back and forth between AF-On and * button. I photograph mainly birds. 
7. I tested 1.5.1 with my rf 70-200 f4 and it froze once, same setup.
8. I've never had an Error 70 message. 

I just wanted to add this information now and I will continue to record the performance of the R5 with my lenses until I can decide what needs to be sent in, the camera or the lens, or lens with extender. At this point I do not know.

My conditions are similar (R5, 100-500mm, without 1.4 - same back button focus arrangement) except that I had many freezes with 1.5 (necessitating removing the battery to fix), fewer freezes with 1.5.1 (just on-off fix). I have not had any freezes with the 100-500mm + 1.4 extender, but have not used it very often. Clearly Canon has more firmware work to do. Love my pix though.

Same here, pics are amazing with the rf 100-500 and the extender. I was out the other day with the rf 100-400 and had no freezes. Camera performed beautifully. I took lots of shots of wild horses on the river. That lens is incredible also. Hopefully, the R5 will work well with all combinations of lenses/attachments. 


issue: R5 camera freeze requiring battery removal to restart. No error message, blacked out display.

I have R5 setup with the star button set to current AF mode/AF Servo. The AF-On button is set to Animal Eye detect.
The shutter button has no focus function, just takes the photo.
I am using a Sandisk Pro 128 GB CF & SD cards. Issue happens during focus, not shutter release so I don't think the card is involved.
I have 3 different Canon batteries and the issue doesn't seem to follow battery or charge level.
I have hit the issue with the RF 100-500 lens with and without the RF 1.4x attached
The control ring on the RF 100-500 lens set to change AF Modes. The issue has happened twice just switching AF mode with the control ring. - rare
I also infrequently use the RF 24-240 lens - Issue has happened with this lens
Issue has happened with firmware 1.4, 1.5 & 1.5.1

Most recently ran into the issue using just the AF-On to do Eye AF focus on a duck with difficult to see eyes (black on black). Camera froze 4 out of 10 times while testing focus. Either it obtained eye focus (blue rectangle) or it froze with a gray rectangle on the birds head, then blacked out necessitating battery removal. My test sequence was to press AF-on to obtain eye focus on the bird, releasing it once it had focus, then repeat. No shutter release during this testing. Full battery, Sandisk Pro CF card, 1.5.1 firmware. 

The problem is infrequent enough that I have tolerated it so far, but annoying enough that I really would like to see it fixed.

Yes, I have tolerated the problem also. R5, firmware, 1.5.1. The camera takes excellent photos and the lenses are amazing, but this is a very annoying problem. I'm a wildlife photographer and I use the AF-On and the * button for focusing. I read on some forums where individuals have never had an issue and seem to think that those that do have the issue have it due to user error. I disagree. No one should be experiencing this issue with an R5. I had the RF100-400 out yesterday with the 1.4x extender to photograph wild horses. The camera performed beautifully and I thought, maybe it is fixed. Well, I spoke too soon. This morning I went out with the same setup and a newly formatted (low format) of card and the camera froze 3 times in about 15 minutes. After that, it seemed to work properly. This is not a user error, but an issue with the R5. 


I am also experiencing same freezing problem even after 1.5.1 firmware update. R5 + RF 100-500MM lens back button Eye auto focus set up.


My Canon R5 and both R6 cameras locked up repeatedly after the update. The battery grip even reported that I was using non-camera batteries when I used the ones that came from canon. The locking up problem is now much worse than before. Please help!!!