Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS M not powering up



I have canon EOS M and I put a fresh charged battery in and the light by the on/off switch started flashing orange in quick succession then went dead. I've recharged the battery, tried mains using a dummy battery set up, again it won't switch on. Does anyone have any remedies for my poorly camera? Cheers 



Well we know one thing for sure it isn't the battery. Try a different lens. You might try a new SD card but that is about all you can do yourself. So repair or replace?

EOS 1DX and 1D Mk IV and several lenses!


Cheers. I'll give it a go


Hey, not sure if you figured it out or not yet, but I figured out how to get my EOS M to power on...

I was having the exact same problem with my EOS M. Mine had been sitting for 4-5 years (with the battery out but SD card still in), I bought new batteries because after charging my original battery, it wouldn't power up the camera. After trying both new off-brand batteries to see if the battery was the issue, there was still no power (though the lens would move a bit when I inserted and closed the hatch).

I'm in the middle of trying to finish a project and was desperate to get the camera working. After pressing and holding every button possible on the camera, I started doing combos.

Pressing a holding the power button along with the "play" button next to the menu button finally got the camera to power up. I couldn't get it to turn off with the power button without being on the LCD viewfinder (like I was going to take a photo) then pressing the power button rapidly (it goes through the normal sensor cleaning cycle before powering off). It may power off on different LCD settings but I didn't want to risk deleting photos somehow considering how wonky the camera is behaving. To power it back on I had to do the same holding the "on" button + the green "play" button next to the menu button.

I noticed the power light doesn't stay on when the camera is on, but that may work itself out over some usage. I literally just got this working and registered on this community forum/page to reply to this comment.

**Edit, 20min update**
****So after taking a photo and powering it on and off a few times like how I mentioned above, the power button seems to turn off the camera without pressing it rapidly, just 2 "normal" times (the first time seems to want to autofocus the lens, then the 2nd time powers it off). I still have to use the "on"+"play" method to power it up (it will turn on intermittently while just pressing the power button by itself, but it's still finicky and may need the combo to turn on), maybe over time the rest of the gremlins will work themselves out.****

**1hr Update** My EOS M seems to be powering on and off normally now for the most part. Sometimes I have to hold the power button for about 10 seconds before letting go (you may have to do a couple 10 second cycles, then press it a few times normally), then it will turn on. It powers off normally after holding the "off" button for a couple seconds if it doesn't power down after a normal button-press.**

I hope this helps!