Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can’t open battery lid on Canon 6D Mark II



I have a Canon 6D Mark II and I’m going to charge it, but I can’t open the battery cover/hatch, I have been trying for 1 hour and it’s impossible to open. Is there a technique to do it? I have tried with thumb and nails, but it’s completely impossible! It does not seems that anything is wrobg the camera, but I can’t open it. I tried with a spoon and a screwdriver, but I was careful to not damage the camera. But right now I need help to open it, it’s strange to ask for help about such a small thing, but it’s not easy to open it. I have opened it before while a person managed to open it before me to show me how I did it, I’m sure it’s a tecnique.

I hope anyone can help!

Best regards,

Gerhard Øpsen



Hi Gerhard and welcome to the forum

Perhaps is you watch the following video linked HERE it might help.  It takes a while for actual process to display, but stick with it or go to timestamp 0:24 sec.  Note the trick is to push the lever away from the closest end of the camera and THEN lift.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris