Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera won't register AF mode

Hi! My Canon Rebel XTi won't register the AF mode on my lens. Currently I'm unable to focus the camera at all or adjust AV levels

I've switched the dial back a number of times, have cleaned the connection spots, cleared the camera settings, and readjusted focus lock etc. But when looking at AF options it continues to tell me to switch the lens into "AF" mode, no matter how many times I switch it to that.

I tried it with a friends lens and it was still the same issue, so I'm afraid something is wrong with the actual camera. I think this came from messing with the shutter button too much a while back. Any ideas on how to fix?


Your description of the problem is a little vague.  Could you be more descriptive regarding what you are trying to do, and what steps you to take reproduce whatever the problem might be.  The most confusing part is what do you mean by “register AF mode”?


What shooting mode are you trying to use?  I am not aware of any shooting mode, or even circumstances, that would cause the camera to give a message telling you to switch the lens to AF mode.


And, what do you mean by “messing with the shutter button”?  Did you once take the camera apart?  Perhaps you did not put back together correctly.  The issue may not be directly related to the shutter, but rather to your time spent tinkering with the camera.


BTW what was wrong with the shutter to warrant an adventure inside of the camera?

"The right mouse button is your friend."


 I think this came from messing with the shutter button too much a while back. Any ideas on how to fix?


That is possible you may have disturbed the AF sensor. I'll make a guess that you were physically moving the shutter and mirror when you mention "playing with the shutter button". The AF works on most of the light being reflected off the mirror towards the viewfinder. A small amount of the light is deflected through the mirror to the AF sensor beneath the mirror. If you touched the AF sensor it is possible it is disturbed. 


This is an older camera. I don't believe they are weather sealed so it is possible that moisture / dirt has collected inside, corroding the electronics. I retired my own Rebel XT when the display wasn't showing the settings. 


You could send it to a camera repair tech, either Canon or a large camera store. However, the repair may be more than camera's value. Because of the extremely sensitive nature of the parts, I would not recommend fixing the sensor yourself.


I'm not sure what you mean by getting an " Turn on AF" notice. I've never seen that on any of my Canon DSLRs.  I do agree that inspecting and cleaning the contacts, checking the settings, and checking with another lens were good process of elimination steps. After that though, any checks generally require more specialized knowledge and equipment. 


Sorry I can't help you more than that.



What lens are you using? Some lenses (including, I'm pretty sure, the 18-50mm "kit" lens for the XTi) don't take well to being manually focused while set to "AF" mode. (I.e., while the "AF/MF" switch on the lens is set to "AF".) The autofocus motor gets jammed, and focusing, by any method, becomes impossible. You don't have to be as forgetful as some of us are in order to have it happen to you. I'm guessing that that may be your problem.


The bad news is that the lens's value isn't high enough to justify paying to have it repaired. A replacement lens in functional condition would probably cost you less. But the good news is that a number of users have been able to restore their lenses to working order by grabbing the lens and focus ring and un-jamming the motor by brute force. There's even a documented procedure of the steps to take. I don't have it in front of me, but it appears several places in this forum. If you can't find it yourself, I don't doubt that one or more of our regular forum contributors can tell you where to look.  Good luck!


BTW, tf this does turn out to be the problem, I hope you didn't accidentally grunch your friend's lens as well!  Smiley Frustrated

Philadelphia, Pennsylvania USA
click here to view the gallery