cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

Camera is not recognized on Windows 10 Laptop

domzrebelt3i
New Contributor

Hello all,

Let me start by saying i am NOT the most tech savvy person. I currently have an old Canon Rebel T3i. It's worked perfectly over the years, and i usually upload using a standard USB. Never had an issue with uploading until a few days ago. I am trying to upload to my new Samsung Surface Book 3 running Windows 10. The issue is i've uploaded photos to this laptop before. All of a sudden, my surface will not even recognize a device is plugged into the computer. I've tried searching for it in device manager, doesn't even show up there. Also, I've looking in devices and drivers while trying to upload to still no luck. Has anyone has this issue using Windows 10 & have anything to offer? Don't want to be uninstalling drivers if it ends up just being a faulty cord. Please help!

 

Very frustrating considering i've uploaded to this laptop prior! ๐Ÿ˜ž

6 REPLIES 6

kvbarkley
Honored Contributor

Have you tried re-booting?


@domzrebelt3i wrote:

Hello all,

Let me start by saying i am NOT the most tech savvy person. I currently have an old Canon Rebel T3i. It's worked perfectly over the years, and i usually upload using a standard USB. Never had an issue with uploading until a few days ago. I am trying to upload to my new Samsung Surface Book 3 running Windows 10. The issue is i've uploaded photos to this laptop before. All of a sudden, my surface will not even recognize a device is plugged into the computer. I've tried searching for it in device manager, doesn't even show up there. Also, I've looking in devices and drivers while trying to upload to still no luck. Has anyone has this issue using Windows 10 & have anything to offer? Don't want to be uninstalling drivers if it ends up just being a faulty cord. Please help!

 

Very frustrating considering i've uploaded to this laptop prior! ๐Ÿ˜ž


Did W10 update in the last few days? There is another thread here with similar report. OP stated there was a recent OS update. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Tronhard
Respected Contributor

As per that other post. You are plugging a USB into your camera, why not plug the SD card into a reader connected to your computer instead? I find it a lot more reliable and efficient to have a card reader (built-in or USB connected). I remove the SD card, pop it in the reader, it gets recognized as a drive and the download options are up to you. The throughput should be faster and you are not using up your camera battery.

cheers Trevor

"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
"A good swordsman is more important than a good sword" Amit Kalantri

Technique will always Outlast Tech - Me

Tintype_18
Super Contributor

Not the most savvy person with computers or anything related. I used a USB cable with our Canon SX530 HD camera but use a card reader with the T7. I find it a bit easier.

FWIW, I have a Dell laptop, Windows 10, and have never had any trouble downloading photos with the cable or reader. But the day isn't over.

ebiggs1
Forum Elite

"Did W10 update in the last few days?"

 

I would check here first.  As far as I know unless the Surface is different there aren't any drivers needed so you can't remove them or reinstall them. At any rate this is a MS Surface issue and not a Canon problem. This is where you need to ask your question. The Rebel T3i hasn't changed but Windoze 10 changes often.

EB
EOS 1DX and 1D Mk IV and several lenses!

FloridaDrafter
Valued Contributor

I use a built in card reader to transfer images, so I can't say that this works for a direct camera to PC USB connection. However, after a recent Windows update (February) some of my older devices could no longer be recognized by Windows 10 via USB (they did before the update). An error message on one of my devices led me to the SMB (Server Message Block) settings in Windows. I didn't think that enabling what is basically a network protocol, would help my USB problems on older devices. But it did in my case as well as solving some other computer shares on my network, which I thought was just some setting I had overlooked when setting up the various computers.

 

This may or may not help get the camera connected, but it only takes a few minutes and a system restart to test it out. If it doesn't work, disable it. Microsoft says it isn't safe. I enable it to connect to the old devices, then disable it when I'm done.

 

I hope this helps, and please report back, good or bad.

 

Start by typing... turn windows features on or off... in the Windows search bar and it will pop up. Click it and you will be presented with the attached window. Enlarge the window, or scroll down to the SMB 1.0 option. Just tic the box as shown, it is disabled by default (unchecked). If it doesn't work, just untic the box. You will be asked to restart your computer on both occasions. I'm using Win 10 Pro, so if you are on Win Home, it may look different.

 

SMB-1.jpg