Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera connect "Conenction to Camera Failed"


I have an EOS R and have succesfully used Camera Connect many times, largely without a problem. However, for no apparent reason, the feature quit working. First I tries uninstalling the app, reinstalling and re0initializing, but it still dropped the connection before even one picture would download (supposedly connecting correctly first). I the remembered there was a new firmware update for the camera so I re-did everything. Installed firmware 1.6, uninstalled the iPhone app yet again, and started everything from scratch. I then took the following steps:

Enabled WiFi on camera. Went in to WiFi settings and started configuration, selecting iPhone and WiFi. Scanned QR code, went into iPhone settings and enabled WiFi and connected to camera, entering the password provided by camera. So far so good, but when I then got the screen reading "Waiting to Connect" and "Start Cannon App Software on the Smartphone" the iPhone screen asked me to select what camera to connect to, showing the EOS R in the bottom white box, but when I selected the camera I got a massage on the phone that reads ""Connection to the camera failed" in the top box.


I look forward to your assistance with this most frustrating issue.





I'm having the same problem with connectivity with my iPhone and T7i.  It had worked fine previously but I've probably connected 100 times so far and every time it either says the connection failed or just drops off.  


I've spent literally hours on the phone with Canon tech support without any resolution.


It ocurred to me to try connecting to a different phone so I did that with the same result - failed! I initially thought it had to be the camera and in fact a Canon rep said I should send it in for repairs. After reading so many posts that others have similar problems though I decided that it can't be the camera.  


I then tried connecting to my computer and it worked flawlessly so the Camera's wifi/bluetooth transmitter must be fine.


I don't know what version IOS you're running but I have 13.3 and I think that may have someting to do with it.  For now, using Canon Camera Connect is not possible.


If you figure it out please share it with me and I'll be sure to do the same!



Enter for a chance to win