cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

“Busy“ on screen of 550D when USB cord pluged into my computer

nuku
Apprentice

In the past I’ve had no problems downloading images to my computer. Now I get the text “BUSY” on the 550D camera screen as soon as I plug the USB cord from the camera into any computer. When this happens, the camera freezes and no camera buttons work. On the Mac I normally use the Canon software Image Utility 2.13.40. With that software running, I get the BUSY text on the camera, and all options on the software window are greyed out. I have not changed anything on the computer.

 

I normally use a iMac desktop machine running OSX 10.6.8, but I have tried OSX 10.8.0, as well as Windows 7 on a laptop PC: same problem. As soon as the cord from the camera is plugged into a USB slot on the computer, the camera says BUSY and freezes. As soon as the cord is removed from the computer, BUSY dissapears and the camera unfreezes. The camera works perfectly as long as it is not connected to a computer, and I am able to take out the SD memory card and download the images using a card reader.

 

I have tried connecting the camera to both the Mac and PC with no image capture software running and I still get the BUSY text. I have tried using a different cord with both Mac and PC the computers: same problem.

I do NOT think this is a computer software problem.

It has been suggested that this might be a physical problem with the camera’s USB slot...

Any suggestions?

 

10 REPLIES 10

I tried this once. It was my last solution. Didn't work. I had lost hope.

Just tried again before calling it a day. Held the camera in my hands, pressing the wire into the miniUSB connector. It worked. Had to register here and revive the post and say thanks. Thank you so much.

Avatar
click here to view the press release
Announcements