cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Live View Has Pixel Problem on LCD - EOS 90D

MortalMatrix
Apprentice

Whenever I shoot in live view mode, there is always an area of the LCD that is comparable to a dead pixel that stands out. The weird thing about this is that after I take the image, the dead pixel vanishes. When I go into video mode, it's not there, only live view photo mode. I attached a video below (I brought the iso all the way up to 25600 with the lens cap on to make it more noticeable.)

4 REPLIES 4

shadowsports
Legend
Legend

Greetings,

I believe you, but I didn't see it.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hey Rick,

It may be difficult to see, but it’s in the top right quadrant on the display. You may have to turn your brightness up to see it.

shadowsports
Legend
Legend

Ha,

I was looking at the faint circle near the play button not realizing that was the center of the viewfinder.  

shadowsports_0-1646885756936.png

 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Yes, sorry, that was my spot metering 😅

Announcements