Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug Report: EOS R8 Magnify Button Doesn't Work in Image Playback - Firmware 1.0.0


When viewing images in playback, the magnify button doesn't work. I think this is a firmware issue because this button is also used for AF point selection when in shooting mode and works just fine. I am still able to zoom in on the images in playback using the touch screen. Canon EOS R8 Firmware 1.0.0. Please help.



Tell us what happens when you press the magnify button.  You need to use other controls to change the magnification factor.

"The right mouse button is your friend."

Nothing happens when I press the magnify button on the R8. The image doesn't zoom in at all. I'm familiar with EOS RP where you press the magnify button and use one of the wheels to control the magnification factor.

After spending some time to read the User Manual the issue is not a firmware bug.  The issue is knowing which is the correct user control to use to control zoom magnification.

After pressing the [MAGNIFY] button, the default control to use to control zoom magnification is the wheel that is integrated into the [ON / OFF] switch.

Users have the menu option to select this wheel, or to use the main wheel as you would with a DSLR.  I programmed my camera to use the main wheel like my DSLRs.

"The right mouse button is your friend."

Would you be able to walk me through exactly what you are referring to.  My magnify button worked one day and then it doesn't now.  Not sure if I change a setting or something.  Thank you 🙂

You have probably changed the default shooting function "AF point selection" to something else, this is all.

Try switching your camera to the Intelligent Auto Shooting Mode.  In other words, turn the to dial to the Green [A+] setting.  

Does playback zoom work now?  As noted above, the magnify button switches the camera to magnify mode.  You use another control, Main Dial(?), to control the actual zoom setting.

If you are still experiencing issues, then please start a new thread for your issue.  Thanks, ahead of time.

"The right mouse button is your friend."


Hi - I just purchased my R8 and am having the same issue. Was glad to see someone else mention it because I thought I was doing something wrong.  Likewise, my button is otherwise functional so this must be a playback bug. 


I'm a new owner of a Canon R8 and my magnify button works just fine during playback. I have Magnification set to 10x on sheet 3 of the Playback menu. I noticed that one of the options is "Actual Size" so maybe your settings are set to this option?

Hi - Yes I took a good look at those settings. I'm at 2x.  I've tried other magnifications as well (and a different initial zoom area via the other option) but no luck.  Thanks for the idea though.