cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

80D Manual Mode - Shutter Speed Disregarded

FredEricS
Apprentice

Hey there,

 

I'm kindof puzzled as to what's going on with my 80D. I've started working with manual mode, first for moon shots with a tripod and connected via the canon app using my phone as a remote. Everything works fine, shutter speeds are regarded and I get beautiful, detailed pictures of the moon. However, when I try to use the camera in manual mode, let's say for wildlife photography - without a remote - shutter speeds are disregarded and the shutter stays open until I press the shutter button again. Obviously, this is not what I want. 

 

Does anybody have any advice on where to look at in the settings (before I reset the entire camera...)?

 

Cheers,

 

Fred

1 ACCEPTED SOLUTION

Ray-uk
Whiz

Make sure that mirror lockup is disabled in the menu.

View solution in original post

4 REPLIES 4

Ray-uk
Whiz

Make sure that mirror lockup is disabled in the menu.

kvbarkley
VIP
VIP

Also make sure the shutter is not set to "B" or any other letter.

ebiggs1
Legend
Legend

" (before I reset the entire camera...)"

 

I would reset it.  You are sure you are in M mode?  If yes, I would reset it. Menu, tools, clear all settings and clear all custom settings.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

FredEricS
Apprentice
It was in fact the shutter lock-up. Thank you very much 🙂
Avatar
click here to view the gallery
Announcements