cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

6D mkii shutter release issue

kmtenor
Apprentice

Hello. 

 

I have a 6D Mark ii that is about 10 months old.  Sometime in the last several months, the shutter button stopped working properly.  On any SLR I've ever had before, when I mash all the way down on the shutter button, the camera fires, and (in High-speed Continuous shutter release mode), keeps firing until I let go.  Suddenly, on the 6D Mk ii, I have to hit a "sweet spot" on the shutter release button, that is just past the "half press" point in order for the shutter to keep firing. If I press the shutter button past the "sweet spot", the shutter stops firing, or won't fire at all.  Sometimes, if I press all the way down on the shutter button, and the camera doesn't fire, as I release the button, it fires once, as the button travels through the "sweet spot".  It's quite frustrating.

 

I am a sports photographer, and have shot with a 7D for many years.  I chose the 6D Mkii to replace an original 5D, because the 6D could shoot at 6.5fps, and had a broader ISO range.  This issue is hampering my ability to get peak action photos during the few games our community is able to hold during this strange sports season.

 

This behavior is exhibited in full manual mode, with AF turned off, as well, so I don't feel as though it's a settings issue.  The longer I try to use it, the more I'm suspcious that there is something physically wrong with the shutter button, but I'm not about to take a less-than-one-year-old camera apart, for fear of voiding the warranty.  I don't believe there was any physical trauma to the shutter button - the case around the button is fully intact, and not blemished.  I've tried blowing the shutter button out from outside with an air bulb (NOT with a compressor or "canned air") to no avail.  I've tried with different batteries, and different settings, including turning off lens stabilizers, and nothing seems to resolve it.  I've even tried shooting in "live view" mode, and the same behavior is present.

 

This has become a reliable enough issue that I would be able to post a video of it happening, if folks are interested.  I have scoured the internet and the forums and have not found anyone with a similar issue, at least not that has described it in a way that I can find it.

 

Thanks in advance for any assistance.

 

-Kevin

 

 

4 REPLIES 4

Waddizzle
Legend

If your camera is less than a year old, why would you want to take it apart.  It should still be under warranty.  Contact Canon.

--------------------------------------------------------
"The right mouse button is your friend."

As Waddizzle advised, get it to Canon for warranty service.  The shutter release is in the most unreliable family of electronic components since it is both mechanical and electrical. That component likely had a manufacturing defect when it was supplied to Canon and has failed at a very early age.  It isn't a common issue but even far more expensive mil spec components have a non-zero infant mortality rate and that rate is tiny but still much higher in mass market components.

 

It will be an easy fix by Canon but NOT something you want to undertake yourself for a camera body that is still under warranty.  Do not be tempted to spray contact cleaners or other magic mouse milk into the shutter button area, it won't fix this sort of failure but it will create a mess AND likely void your warranty.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

kmtenor
Apprentice

Thanks, guys.

 

Sound advice.  Rest assured, I've done nothing to void the warranty and had no intentions of trying to repair it myself.  I was just hoping someone else might have encountered this before, and I was overlooking it in the forums.  First call tomorrow will be to Canon for service instructions.  It's a shame to lose the body for what's left of this season, but better to have it fixed and working properly for whenever we get back to playing.

 

Thanks again.

 

-Kevin

Hi,

I have the same problem. May i ask what was the solution?

Thank you!

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.