cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mark III selected AF points not illuminating red

Mike14
Apprentice

I have an EOS 5D Mark III that I am trying to learn how to use.   A couple of online training videos (and some Internet searching) seem to imply that after pressing the shutter button halfway, the AF points that the camera has selected should display in red.   The selected points do show up as black outlined squares, but they do not turn red.  Is the camera not working correctly?    

11 REPLIES 11

Anonymous
Not applicable

The AF points only illuminate for a brief second when focus is achieved. The On Enabled setting for illumination causes them to briefly turn red at focus under any lighting conditions. The auto setting for AF point illumination will cause them to briefly turn red only when the lighting is dim, but not turn red when the lighting is sufficient. 

The AF point selection set to 61 point automatic, is setting the camera to use all 61 points to find focus, and has nothing to do with AF point illumination. I recommend using the center single point for AF point selection.

Your camera is fine and working the way my 5D Mark III works.

If you feel comfortable doing a firmware update, update the firmware to 1.3.6 as it does the following:
Firmware Version 1.3.6 incorporates the following fix:

1. Corrects a PTP communications vulnerability.
2. Corrects a vulnerability related to firmware update.

Mike14
Apprentice

Ok, thanks.   Good to know the camera is working ok, I'm going to spend some time with the manual and the camera, and then I'll see about updating the firmware.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements