Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 70-200mm F2.8 (non IS) USM L focus range problem

Hello everybody! I recently bought the old very old Canon 70-200 2.8 non is L, used and damaged, falling was it's problem. Both rings were stuck because the lens did bend a little and the index barrel (I believed is it's name, the one in the middle of both rings) did crack and stuck them hard. I tested the lens before opening to check for AF, it worked but the focus seemed out of range, could be because something was loose inside I though. To repair it's visible problems I glued the the cracked barrel and sand down to live the rings rotate freely. It worked and all mechanisms work OK because the bend did not affect enough to stuck the insides. After all this, the assemble went well, but, it keeps focusing, out of range, as it try to focus, the AF does its course, from 1,5m to infinity, but it looks like if it came a little bit more, it would focus. It's not focusing Macro either. So I believe something was bad assembled before it arrived to my hands as I did the exact same steps reversed to disassemble. I think it can be some lens on backwards (weird but it happened to me one time on an old lens maintenance and the diagnostic was the same), some lens missing (one of the lens groups misses one lens, I don't even know if it is possible) or anything else. I have now this brick on my desk! Did anyone ever passed something like this? Does anyone know something that I can be possibly missing? Please help if you have any ideas! Sorry for my bad English and good 2019! Regards, Nuno Rodrigues...


If you go to (Link removed as per Forum Guidelinesyou can purchase a parts list for your lens. It may help you.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Hi John, sorry but the link vanished! But it's OK because I also followed the part list pdf, found it free, it would be useful the full repair manual from Canon, but it costs money but, I will do it if no one can help me here! This lens is so old that the information available online is very short. Thank you John...


I purchased the old lens as you and tried to fix myself as my winter hobby :-). The autofocus issue can vary from lens to lens. The most possible reasons could be:

1. the broken flex-cable. 

2. the old not function well USM motor.

3. the dirty status ring inside to tell the position of the focus ring.

4. the main circuit board that drives the USM motor.


You need to fully disassemble the lens and visually to judge where the problem is.


Good luck.



Fsong00, hello! it all works! The rings turn, the autofocus does the all path from 1.5m to infinity, and the camera completely works with the lens. The issue, seems to be the range of the focus. I bet on some hypothesis, lens on backwards, or the previous owner who tried to fix it, did replace some lens group for some compatible but not the right one! I tried to mount all the groups of lenses on various positions, but it only assembles on the right one I guess, it's impossible to mount it wrong? What do you think? Thank you!! Regards

From what you described:


"To repair it's visible problems I glued the the cracked barrel and sand down to live the rings rotate freely. It worked and all mechanisms work OK because the bend did not affect enough to stuck the insides."


It looks to me the previous owner did not try to fix it. Or not try to replace the backward lens groups with some compatible version.

What you got should be all the original. Usually, the lens track for focus groups to be on track with the middle barrel; then the middle barrel on track with the outside zoom barrel should be unique and no ambiguous. You never know what the previous owner did with the lens to cause those out of track problem. I am very happy to hear by adjusting the mechanical track and you fixed the problem. Congrats.



Yes it became functional, just needed to sand some high spots on barrels there were rubbing too much, lubed it all and all went well smooth. The focusing elements (I think it's the second lens group) moves ok and inside its range I guess, buts that's not enough to focus on any plan, the focusing is beyond the infinity for what I can see... It's not so much info about this lens repairings. Thank you Fan!