cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can´t remove UV filter from lens

mjroberts
Apprentice

I am using a UV filter made by Zeikos on my Canon lens, but I cannot remove this (it has become stuck on the lens). I am worried about forcing it due to the risk to the lens. Can you recommend a product that can be used to help loosen the UV filter? I currently live in the Peruvian Amazon so mail order of a product is not possible, rather I need to know what can be used so I don´t put anything on the lens that could damage it. Many thanks!

1 ACCEPTED SOLUTION

jcphoto
Contributor

A fat rubber band works a charm for this problem. Just wrap it around the filter, it grips well enough to allow for most stuck filters.

View solution in original post

24 REPLIES 24

He has a T7I


@Knapjb3 wrote:
He has a T7I

If he has a T7i, then it is likely that he has STM version of the 18-55mm lens.  The “fix” I posted above does not apply to STM lenses, because they have manual focus override.  

When you say the lens “does not work”, does that mean it no longer focuses?  Is there an aperture problem?  What exactly?

--------------------------------------------------------
"The right mouse button is your friend."


@Knapjb3 wrote:

My son was apparently having this problem. Im guessing that he forced it, and he said he heard a popping noise, the lense retracted and now will not work. 😞 So, I don't know much about cameras. Does anyone know if this means that the lense is now completely broken. Is it something that can be fixed? Any help would be greatly appreciated. 


You say the lens dos not work, so I assume that means it refuses to auto focus.  You mention is was an 18-55mm lens.  If he heard a popping noise, then he could have dislodged the AF motors from their intrernal focusing lenses.  He may have been holding it by the focusing ring.  It also sounds like he tightened it far more than need be.  A lens filter only needs to be snug.  Temperature changes can cause filters to become really tight, which necessitates the use of a lens wrench to remove the filter.

 

This is not an uncommon problem for the older 18-55mm lens designs.  The lenses lack a manual focus overrride feature, which would allow the user to turn the focus ring when the lens is in AF mode.  The older lenses, EF-S 18-55mm f/3.5-5.6 IS II,  do not have manual override, so turning the focus ring can jam the AF motors.

 

https://community.usa.canon.com/t5/Lenses/Autofocus-not-working-18-55mm-lens/m-p/138114#M5459

 

Please refer to the third post by Canon Product Expert Julius in the above thread.  He describes a fix for unjamming the AF motors on a specific lens model.  I suspect that your issue meets the description.  Read the first page carefully.  Later posts describe problems people have experienced, and what they did to correct their issue.  

The fix is not for the faint of heart.  You must twist the lens as he describes until it “pops” again.  It will seem as if you are destroying the lens, which is not far from the truth.  But, the lens is already ruined in its present state, so what is the worst that can happen.  The crunching popping sound would hopefully be the AF motors popping back into place.

This is not an uncommon problem because new users frequently look through the viewfinder, while reaching up to turn the zoom ring.  But, they turn the focusing ring, instead of the zoom ring, and jam up the AF motors.  I have done it, too.

--------------------------------------------------------
"The right mouse button is your friend."

Knapjb3
Apprentice
Yeah, the lens doesn’t focus and when twisting the lens it doesn’t move.

Aidentmg
Apprentice

Try wrapping the lens with duct tape with towel and turn it forcefully, try to not extend the lens. Remove the lens from the body before trying it. It worked for me. I tried using a plier but it badly damages the uv filter making it impossible to remove it with bare hands. I tried alll possible method that I found online but it failed, instead ended up having a saw stabbing my index finger.There was a duct tape on my table so I tried using it before giving it to the repair store and it worked like a charm. 

Avatar
click here to view the gallery
Announcements