cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

24-105mm L Image Stabilization Issue - Only Works on Live View

massimo_st
Contributor

I recently purchased a 24-105 L IS lens and mounted it my EOS 1D X Mark II body. Oddly the IS works fine when I use Live View the IS works fine but as switch off Live View, the IS shuts down on the lens. I can hear it spin down and as soon as I turn Live View back on, IS starts up again. Anyone have any idea what is causing this problem? I appreciate any help or thoughts.

Thank you

6 REPLIES 6

kvbarkley
VIP
VIP

IS should start up when you half-press the shutter. This feature is to save the battery.

I agree but it doesn't.   I half press and get a focus lock but no IS.

shadowsports
Legend
Legend

Greetings,

New lens, used lens?  Are you seeing a hand with an interdiction symbol in the viewfinder or LCD?

Reset your camera's main and custom settings, then retest.  

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

It’s used.  Thx for the reply.  I have already returned the lens but I might get another and I’ll try your idea.

ebiggs1
Legend
Legend

Yes, my guess the lens was faulty.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

massimo_st
Contributor

I returned the lens to the seller and they said when tested on a EOS 6 and it worked fine.  

I ordered another one 

Avatar
click here to view the gallery
Announcements