Showing results for 
Search instead for 
Did you mean: 

what is error 5100 for multifunction printeers and how do you fix it?


what is error 5100 for multifunction printeers and how do you fix it?


Canon MX700 - error code 5100


I've cleaned the plastic strip, restarted it several times, checked for blockages, and still getting error.  The print cartridges are hidden behind the plastic housing and I can't get them to slide out so that I may inspect the condition of the cartridge.  Help?

The printer copies just fine.


Today, it stopped printing half way through printing out a 16 page document.


I followed the instructions to check the cartridges to make sure they were installed properly, turned off the printer as directed and turned it back on. The 5100 error code came up.


I also noticed that several sheets of paper had inadvertently entered the slot where only one piece of paper at a time is supposed to go.


thanks much for any help.



I was so happy to find out about this upgrade!!! Finally! Not only an upgrade to 3D printing, but printing food too!? So far, I have only printed ham, but I am looking forward to printing bacon and sausage tonight too!!!


Thank you, Canon!!! Best driver update ever!!!


@mediatrek wrote:

Usually an error 5100 code is saying that the ink carriage has problems. Usually something currently is or recently hammed the cartridge carriage. With the machine turned off and the power cord unplugged, open the machine and inspect the inside do you see any stray pieces of paper along the paper's usually route?

There is a way to reset the machine to clear out the error. I would need to know the exact model of your Canon.



my machine is a MB2020 Maxify

I have an MP250 and I have that error. A stray piece


follwed instructions for error 5100 luck. Should I reset and if so, how? PIXMA MX850

Hello bcainey,


To try and resolve the issue, please follow these steps:


1.  With a flashlight or other bright light, please check the paper feed areas of the printer and verify that there are no paper jams or obstructions in the printer that may be causing the error.  


2.  Look inside of the printer where the inks are located and ensure that there are no obstructions in there that may be causing the print head not to move freely. 


3.  Remove and reseat all of the ink tanks in the printer. 


If you still experience the same error after performing the steps above, the printer will require servicing to resolve the issue.  Please click on the Conact Us link below to obtain your servicing options.


This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


Ok my printer is having the same problem, I have a MX340. Can you tell me how to get in and check it? thanks.

Hi! My problem is quite similar to others' however, my Canon Printer is an MX340 model. It was working perfectly for a while but lately I have received the "Printer Error has occurred 5100" prompt. I have tried opening the printer and looking around for pieces of paper, etc. and even cleaned the inside which had some ink in it but the prompt still appears. In addition, I have: Turned the printer off and removed the wall cord temporarily to look insider further. But the problem persists. Basically, when I try to print, besides the prompt given as above, the ON light is blinking and so is the "Alarm" button. I am wondering if perchance it needs the drivers updated? If so, where could I find them? How can I rectify this problem to get my printer to work again as before? Thank you for your help in this matter.

I just wanted to add that when the printer tries to print, if it's a farther clue to something, I hear a "click, click" noise coming from inside like something is trying to move but can't. Right after that the ON light starts blinking and the Alarm button also starts blinking. Canon M340. Thanks again!