Showing results for 
Show  only  | Search instead for 
Did you mean: 

Won't scan mp830


My MP830 stopped scanning and copying.  It will print just fine.  The light source does not come on.  The focusing bar does not move across the platen.  I have unplugged the printer overnight.  Still will not scan/copy.  There was no new software added proximally.  Vista ultimate 64.  HP Touchsmart tablet.  This set up worked for years.  When I got a 6A00 message, I cleaned the plastic blades and reset the sponge and the 6A00 message stopped.  I don't think the copy/scan issue is related.  Any suggestions?  Thanks in advance.




My mp830 won't scan - it displays a box to select a software (abby fine print was in there - selected it nothing happened, so I un installed it, and reinstalled canon drivers thinking it would install but nothing showed up...).


Running Win7

Hello jmt200.


Please download the MP Navigator to scan with the unit.  The program can be downloaded from our website at the following link.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



You F-ing NAIL IT dude!

I'm a CPA (non-practicing - fortunately too, given I'm having the same problem that got me to your post), and you had me in stitched reading your post. I couldn't have made it up the way you recited it.


Now what are we gonna do with Canon?  If mine is the same problem of a light buld they don't carry...  imagine Mercedes telling customers 'sorry - we don't support your 5 year old vehicle anymore'.  This is just plain and simple BS.  And I will never buy Canon ANYTHING again if I can avoid it.


<IDEA> - youtube of my MP830 being shot and/or exploded to bits, along with the story, to see how many other customers I can scare away from Canon?  Buy a 1000 backlinks on fivver?





PS - almost forgot:

have to bag on Micael in Canon support (posted at the top).  What the H is up with the logic that the lock mechanism suddenly locked itself???  That could start a whole new thread on 'experts' - across all fields.  Or a thread on 'my time -  wasted by experts'.


I have the exact same issue with the MP830. And just by looking at the dates it indeed appears to be planned obsolescence. I had not used the MFP too often, and when I bought the device it was not at all a cheap one. 


I do not have $$$ for a new one, and even if I had, I would refrain from buying another Canon.  


I have the same problem with the cannon mp 830, will print but will not open the scan window since i downloaded

osx mavericks 10.9.1. this is where i think the problem is and not a burned out bulb. cannon support site says they

have no drivers to support Mavericks for the scan part of the mp 830. I called Apple and they offered no help unless

you wanted to pay them 20 bucks,then they would Trouble-shoot your problem. Mine had been working fine till i

downloaded osx mavericks. Now the Navigator will not work either. 

"Uh, yeah. . . ." "What's this I hear, you're having trouble" scanning "your TPS reports?" "It's just that" Canon is "putting new cover sheets on all" of its PIXMA multifunction printer-scanner-copier machine boxes now. "Did you get that memo???" Ya see, Canon has a "coach roach problem down here" in "the basement" and it's told each of us to move our "desk to the basement", "get a can of pesticide and a flashlight" to fix the scanner light bulb problem, and . . . "turn off the lights down here" when we're "finished." If we can all "remember to do that in the future, that'd be great. . . ."



This may be a little old now, but  I too had an issue with scanning on the MP830 also. Printing was fine. 


I have Windows 7 (32bit) OS.


It was working fine the other week, but had to reinstall the programs and drivers since my windows had to be updated and reinstalled. After that happened it stopped working. I remembered I had to do something before in the past to get it to work again as their installation programs were missing a step so it seemed.


But found this link that might help? dating back to 2011


It talks about updating the windows System Path settings after you try to scan and fails.

Once the program fails to scan, a MP830 folder is created in the following area:




I just added this to the existing Windows System Path settings, or created a new path setting if one didn't exist. 

And then close the MP Navigator 2.2 program if you have it open. And then load it up again.


The program now allows me to scan.


Hope this helps you all.


Thanks for posting your suggested fix. I tried it, and as I expected, it didn't solve the Pixma MP830 scanner problem. That's because your suggested fix is a software ("Navigator") fix, not a hardware (the burned out light bulb) fix. It worked for you because you had a "Navigator" software problem immediately after reinstalling your computer's Microsoft Windows operating system, which is also software, not hardware. Anyway, because of your thoughtful and sincere suggested fix, and your thorough research, I'm gonna tell "the Bobs" that you deserve a promotion!


Just for the record I want to be added to the dissatisfied Canon MP830 scanner users crew. Identical failure after rarely using the scanner over the past 5+ years. Frankly given how I've seen most companies respond to these type complaints over the years we'd all get better results urinating against a hurricane after drinking a case of beer. Or maybe writing one of our representatives in Washington, DC. It's the way of the world.

Is anyone here so disgusted they are ready to sacrifice the possibly still fundtioning printer (one forth of all the functions, now that the other three don't work) to make a point?

I would LOVE to see someone go on camera with their MP, explain the problems we've all had with the printer and with Canon, and then blow it up!!!  Buy 500 backlinks for $5 and make sure its the first video anyone googling 'canon' ever sees.  Would really serve the biotches righttttt!!!! lol