Showing results for 
Show  only  | Search instead for 
Did you mean: 

Won't scan mp830


My MP830 stopped scanning and copying.  It will print just fine.  The light source does not come on.  The focusing bar does not move across the platen.  I have unplugged the printer overnight.  Still will not scan/copy.  There was no new software added proximally.  Vista ultimate 64.  HP Touchsmart tablet.  This set up worked for years.  When I got a 6A00 message, I cleaned the plastic blades and reset the sponge and the 6A00 message stopped.  I don't think the copy/scan issue is related.  Any suggestions?  Thanks in advance.



I had this problem and fixed it.  I wrote up a giant reply here detailing how I fixed it but it disappeared/got deleted?

In a nutshell, the problem was the flex cable connecting the moving scanner head to the edge of the scanner (under the platen).  That cable curls and uncurls as the scanner head moves, and in my case, one of the conductors inside it broke.  


I figured it out using a multimeter at each end of the cable and found that one/some conductors didn't work.

See the kink on the smaller cable?  That's the broken one and probably where it broke.  

I fixed it by buying a similar flex cable (hard because of the length) "A1 FFCs - Long Flex Cable for Raspberry Pi Camera - Black 1m/3.28ft (2 Pack)" on Amazon for $7.  The important part was the 'pitch' — the space and width of the conductors — since it needed to slot into the existing flex cable ports.

I removed the old cable, cut to length, trimmed off the unneeded lines (I think there were more conductors than I needed) and scraped off the plastic at the ends to reveal the conductors which I connected to the flex cable ports.

I was happily surprised that it worked — it was a kind of a shot in the dark!  It was pretty major surgery but it's still working years later (with light use).

Putting this info here in the hopes that it helps someone else.  I can't believe I did all this but this is a great machine.