cancel
Showing results for 
Search instead for 
Did you mean: 

What was fixed in the firmware for inkjet printers that continuously reboot or power down?

5150
Contributor

As the title asks the question…what happened that caused all of the printers with internet access to behave the way that they did on the 31st?

I think in the spirit of transparency that we should be given an answer as to what caused the problem. Also, what was added to the firmware update that fixed it? I’m curious because I’m not updating my firmware because changing the DNS manually allows me to print without issue. Is there any benefit to the firmware update other than web services or over the air firmware updates?

11 REPLIES 11

martharitte
Contributor

I am no computer pro, but i was unable to download the updated firmware, and have no idea how to manually change DNS.  I could not get the connection between printer and computer with UBS.  Is this printer worth me persuing profession IT services?  Thought?

What model do you have? My model is the MG7520. If you can disconnect from internet (turn off router, temporarily  unplug modem from router, etc.) it’s very easy to change the DNS under web services. The difference my be that your printer doesn’t have the same menu but it should be very similar to this:

MG7520 Web Services DNS change 

After pausing your internet connection:

  • Turn on the printer
  • Slide the lcd printer menu to the right and tap setup
  • Tap Web Service setup
  • Tap DNS server setup
  • Tap manual setup
  • Change the value to 192.168.000.199 (write down the old value in case you want to change it back later)
  • press “OK,” and then press “no” for a secondary DNS server.

Power down your printer and reconnect to the internet. Your printer should now function normally.

The only thing I would change is the DNS IP. Instead of 192.168.00.199 use 000.000.000.001 That seems to be the IP address that Canon support offered during a call.

I have a MX 490

It looks like your path to the dns change on the printer would be:

  • Press setup button
  • Use the left/right arrows to find device settings—press ok.
  • Use the left/right arrows to find Firmware Update—press ok.
  • Use the left/right arrows to find DNS Server Setup—press ok.
  • select manual and follow the prompts to change the IP address

Cant make any changes because

1.  Nothing works on printer except looping;

2.  Downloading firmware using Canon web does not work, and

3.  Computer and printer will not communicate with usb

You disconnected your WiFi/internet access before turning on your printer?

exactly. I am not able to do the firmware and no clue re: DNS. Fix this Canon

Janiece87
Contributor

I tried the firmware update and I don’t get the box show in the instruction for number 4-6. I decide to do away with wireless altogether. I bought a usb cord from Amazon. Here are the steps to go the USB route If you choose to. 

Unplug printer and modem

Wait 5 minutes then plug printer back up

Reset wireless network settings to factory default settings

  1. Press the Setup button.
  2. Press the right arrow until Device settings appears, then press OK.
  3. Press the right arrow until Reset setting appears, then press OK.
  4. Press the right arrow until LAN settings appears, then press OK.
  5. Press the left arrow to select Yes, then press OK.

Download your printer Driver CD

(If you don’t have it, you can get it free in Canon website. Search your product and download)

Be sure to use a USB cord and you can print now!!

If you have a Mac go in system preference>printers and scanners> delete the printer by clicking it and press “-“ (minus) button (because it’s looking for wireless connection) then press “+” (add) button and it will add your printer back.

I will NEVER use wireless options again. This has been a NIGHTMARE!!! Shame on you Canon!!

 

cmkessell
Apprentice

I'd be interested to know too.  As far as I can tell the firmware in my Maxify MB5350 hadn't changed (it's version 4.00, and has been for some time), yet suddenly it was rebooting constantly.  

But I suspect Canon will simply pretend the problem never happened. 

Also I wonder how many people, believing their old Canon printer had broken, have rushed out and bought a new machine. 

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x