Showing results for 
Show  only  | Search instead for 
Did you mean: 

TR8620a Does not Scan Properly


About a year ago I bought a TR8620a Printer/Copier/Scanner.  I do a lot of scanning and my previous machine stopped working after about 6 years.

I cannot get this thing to scan more then a page or two.  I am using it wirelesly but have also tried connecting with LAN cable. 

I always get this message when attempting to scan.  


When I hit the scan button on the Canon Utility I can hear the scanner working, then this pops up. 

Also, when I attempt to use the document feeder to scan the second page always jams and I get the above message.

I have looked at all the sites I can find and downloaded update after update.

In all the years I have worked with technology I have never had this may issues with a piece of equipment.  I am ready to donate this machine to a landfill.



Thanks for joining the conversation, kasy!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or macOS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Enter for a chance to win