Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma mx922 not powering on


My PIXMA MX922 was purchased new in 2015.  It has been working fine since then.  Starting today, the printer will not power on properly.  When plugging it in, the small blue LED on the "COPY" button illuminates.   However, pressing the power button does not power-up the unit. I verified that the outlet that the printer is plugged into does in fact have power.   I've also tried it with a power strip (rather than plugging directly into the wall).   No go. 


I have tried disconnecting the power cord for various times (10 minutes, 15 minutes, 30 minutes) then reconnecting it, with no results. 


Appreciate any assistance you can provide.



Excellent troubleshooting on your part.  Unfortunately, it doesn't sound good.  Sounds like the printer's power supply or controller board has failed or malfunctioned. 


Last step.  Press and hold the power button for 30 sec.  Now disconnect from the wall outlet..  keep pressing the button.


Now release the button.  Wait about 30 sec, reconnect to power and press the power button again to turn on.  Works, great..  


If no...


You can contact canon and investigate repair options, but I would replace it given its age.  The cost to ship and repair often exceeds the cost to replace it.      

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It