Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA TR8520 Not Printing Black in Documents


Suddenly having the same blank page printing problem on my Pixma TR8520, I went through PEdit's steps (save for 5-7), and the print nozzle check pattern test page printed out absolutely fine. But I'm still printing out blank pages from applications. 


I noted, though, that when I went to print out a PDF document from Adobe that was all black text except for a color image of my blue ink signature that I had inserted, only the signature itself printed out. Then it occurred to me to try changing the color of the text in an MS Word document from black to blue to see what would happen. The doc printed out fine with blue text. Going back to black, not at all.


This is not a problem with the black ink cartridges or nozzles. As you can see from the print nozzle check pattern test page below, black printed out just fine. It's only when printing from applications that black doesn't print out. 


I'm totally stumped. This printer is just under 2 years old. I bought it at Best Buy for $80, and the same model is now $180; similar models have had the same jump in price. So it's not as easy to give up on a "cheap" inkjet as it used to be, 'cause they ain't cheap anymore. 


Canon Print Test Page.jpg



Having exact same issue.  Any resolution?

Yes and no. Support tells me that there should be two black printouts on the print nozzle check pattern test page shown above corresponding to the two separate black ink cartridges—the one missing should be on the top, and it's for the thick black ink cartridge. Support suggested (and sent me gratis) a new ink cartridge to see if that would fix it, and said if it didn't, to clean the print head. Neither worked. According to support, there's nothing else to be done, and I'm welcome to buy a new unit from them at some presumed discount.  

I had the same problem.  Finally after deep cleaning several times, which did not work, I replaced the 280 XXL black cartridge which was empty anyway.  That solved my problem.   


I can only guess the black ink in the cartridge was somehow defective.  It was not supposed to be a recycled one that I purchased from Amazon.

click here to view the gallery