Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MX452 Filter failed error with new macbook




I'm an older technically challenged guy who's having a difficult time attemping to connect a new Apple Macbook pro to an older mx452 printer.


I'm operating osMojave version 10.14.5.


I installed the driver from the Canon website.  When attempting to print, the printer acts like it's going to print and then I get a "filter failed" message.    The apple website mentions something about 32 bit and 64 bit but also says Mojave is the last operating system still using 32 bit.  


Can anyone help?








I followed the steps you mentioned above to re-install my work printer (imageRUNNER ADVANCE 4535i II) on my Mac running on Mac OS Big Sur 11.5.2. I have made it to downloading the installer but the printer is still not showing up as a choice to be added to my list of printers. I have restarted the computer, too but still nothing. Any other ideas?

Dear Patrick, you were sent from heaven!  I've been working on this issue for hours, frustrated that Canon no longer supports my Canon Pixma MG8220.  Then I found you and followed the 14 steps you wrote for Smokeymac2. I've never been so happy to see paper come out of the printer with ink on it. Thank you for sharing your expertise.  It was very detailed and presented in a very nice format.  I'm over 70 and barely keeping up with the ever-changing technology!  Thanks, again.  I really appreciate your help and will sleep better tonight!  cambaker


Hi Patrick,

Having issues with the filter failed error.                                                                                                                                                                                                                                                                                                               My Canon ip100 worked with my printer via USB. I then remembered I could connect it via Bluetooth. I deleted the printer under system preferences>printers and scanners. That didn't work.                                                                                                                                                                                                                                                          I don't care about Bluetooth anymore. I tried to reconnect it via USB and now I'm getting the filter failed error code.                                                                                                                                                                                            I recently did an update and am currently running Mac Monterey 12.3.1 on a Macbook Pro from 2015. It doesn't look like there's a driver available for my computer and OS. I downloaded something called image garden v366 since I found it under my search for canon ip100. It didn't help.                                                                                                                                                                                                                                                                                         I cannot follow your steps 6-8 below. I can get to the finder but when I search for  /Library/Printers/ nothing comes up. I also do not see anything under just printer, canon, or library.  Can you please advise? I've been at this for hours and Canon no longer supports this product.

5.  Click once on desktop so Finder appears in upper left corner.

6.  Click on Go and then Go to Folder.

7.  In that box, type:/Library/Printers/and click Go

8.  In the folder that appears, please delete Canon folder.


I had a “filter” fail error on Canon Image Class MF3010 both trying to print online as well as when downloaded on to my Mac Sonoma 14.2.1 computer. The solution was to Control + click on the name of the file on my computer in Finder, Open With, Change to Mozilla Firefox. It would open and then print.   ..    ..    ..   Then I changed the default PDF viewer on my Mac computer which was Preview. It wasn’t working on my Mac giving me the “filter” error. I Control clicked the name again, clicked Get Info, then scrolled down to Open With and the drop down menu has Default, click that and scroll down to Firefox and make that your default Open With.  Wishing everyone drama-free printing!