Showing results for 
Show  only  | Search instead for 
Did you mean: 

No power to printer TR4722


I just purchased a TR4722 from Walmart 27 days ago.  It was working great.  This a.m. I noticed on my router list of connected devices was one that I didn't know.  I renamed my router I.D. & changed my password.  Then I went through & reconnected all my other devices, 2 Chromecasts, cell, laptop & Google Mini.  I saved for last my printer, because I thought it would be the easiest as it's the newest.  When I went to reconnect my printer to my internet I saw I had no power.  I've tried unplugging the power cord at the printer, then tried at the outlet, tried hitting the link button, tried going through the app, even tried sending something to the printer from my laptop to print.  I did notice that early this a.m. while checking my email from my phone, tried sending something from there, still nothing.  I can't get power at all, should I just box it up & take it back to Walmart?  Any ideas?

Thanks for the help.


Product Expert
Product Expert

Hi EdS,

It is recommended that you contact technical support for further assistance.  A Technical Support Representative can determine the cause of the issue and resolve it or provide you with your available service options.

To call for support, please create a My Canon account:

Once your account is created, you may call in by dialing 800-652-2666 or chat by clicking the chat button in the Service & Support menu.





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks for your help.