cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No compatble printer installed per Pixma MP470

GleasonRules
Apprentice

I went to the drivers and files page for our Pixma MP470 to see if any drivers were needed for macOS El Capitan. None were shown but Easy Photprint was shown, so I downloaded it and then installed it. When I tried to run it I geta no compatiple printer is installed error message. Funny, the printer shows up in El Capitan plain as day. What's up, Doc?

3 REPLIES 3

ArthurJ
Product Expert
Product Expert

GleasonRules,

 

While the printer appears on your Mac, there are no drivers available and that is why you are getting a error message. The MP470 has been retired and the last drivers made were for OS X Mavericks 10.9.

 

Since the printer is not compatible with your operating system, you qualify for the Canon Upgrade program.

 

This is for out of warranty units which have been diagnosed to require service or are incompatible with a new or upgraded system. This program allows you the opportunity to purchase a replacement product discounted from the list price. Free ground shipping is included with your purchase.

 

If you would like to take advantage of this offer, please call our Sales Department at (866) 443-8002 mon-Sat, 9 AM to 9pm EST. Let them know you have been working with technical support and that the Canon Upgrade Program was offered.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Question. When I search on the other English Language Canon sites they ALL say Easy Print 4.7 is compatible with El Capitan AND MP470. So why the error message? Even loading Gutenprint didn't help.

Hi,

 

The printer appears because it is most likely using Apples generic printer driver. The Canon driver would provide full functionality of the printer. Since there is no Canon driver to install, you will continue to get that error.

 

You can try downloading and install the OS X Mavericks driver by clicking the link below. Please be advised the driver for Mavericks was not tested in the El Capitan operating system so I can't promise it will work.

 

mcpd-mac-mp470-10_84_2_0-ea13.dmg

 

After you download and install the file, go to printers and scanners and remove the printer. Once the printer is removed, try to add it back on and print.

 

If you still get the error, I recommend the Canon Upgrade program.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Announcements
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available forRF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!