cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NEED TECH HELP! - MG6620-Won't stay powered on- for lots of us

sheri99
Enthusiast

I've found several posts in here that jus over last weekend (which is when this started for me) the printer is powering itself off and won't stay on. I've unplugged, waited, replugged.  Plugged it into the USB instead of using wifi. Nothing helps. My printer will not stay powered on.  Someone at Canon has to know about this and hopefully working on a patch or something?  I need my printer! 

1 ACCEPTED SOLUTION

SamanthaW
Moderator
Moderator

Your satisfaction is important to us, and we apologize for any inconvenience you may be experiencing.  A firmware update is available to fully resolve this issue.   You can download the firmware update and find easy installation instructions at canon.us/power.

View solution in original post

10 REPLIES 10

tahoemarta
Apprentice

Are they ignoring us? Is this Canon customer service at its best?

Olmbre
Contributor

MG6620, same issue, same timeframe! I would say caused by Canon definitely!!!

sheri99
Enthusiast

After a 1:57 hold time with Canon customer service.... I have the solution! (and that was 2 hours, not 2 minutes) If this is happening to you it is very easily fixed. [Removed per forum guidelines] Although I wish I could sell it to make up for my 2 + hours of time.  Here is what you need to do to fix it:

Completely unplug your router and then turn on your printer (it won't stay on if your router is because of a linking problem with the router, that we are going to fix.)  So this is the step-by-step for the MG6620 and probably those models with similar menus, but whatever model you have just try to get to your DNS Server Setup. That is where the setting is that needs manually changed. So for the MG6620:

On the menu swipe to Setup, then find Web Service Setup then DNS Server Setup. Select Manual.  Press each set of numbers and change them all to 000 except the last set. That needs to be 001. So your DNS will look like this: 000.000.000.001  Click OK, then click No.

That's it. You should be good to print.

You are welcome!  Too bad someone at Canon doesn't just post this somewhere. Would've save a lot of people a lot of headaches, I'm sure. 

 

To get to the DNS settings, from the main screen choose Setup > Device settings > Firmware update > DNS server setup > Manual setup

Your solution worked. Thanks so much.

Thank you! I was just about to buy a new printer when I thought I’d try another search to see if anybody else had the same issue. Your solution was the one that fixed my issue. I agree that Canon should put this up front and center on their website. 

I signed up for the forums just so I could come in and tell you this worked!

 

Randomly this issue happened to my printer just today. Printer made weird noises when trying to turn on, wouldn't get past its bootup display before just powering off. I got the 300 error, I tried removing and re-adding the printer, turned off wifi, all that. I'm on macOS 10.15.7 Catalina, I did the reinstalls, I did the drivers, hardwired via USB, etc. I work in tech support and I was so mad I couldn't figure this out.

This turn on the printer without the router on WORKED! THANK YOU! I was screaming how fast that fixed the issue. You rock.

Thank you so much for sharing this info!! Worked!!! They definitely should post this somewhere!!!

xDetoursx
Apprentice

This just started happening to me too.  I upgraded the firmware last week and one night I came into the office and the printer was completely off including the blue wifi icon.  When i turned it on, it started working normally.  Then it did it the other night, but this time it wouldn't stay on.  Seems like the firmware upgrade messed it up.  Haven't been able to try the fix yet as I have about 17 devices attached to the router with other people in the house, so it's not so easy for me to just unplug the router.

Avatar
click here to view the gallery
Announcements