Showing results for 
Show  only  | Search instead for 
Did you mean: 

Magenta cartridge not recognised, no light in cartridge slot




I have a Pizma iP4300 which has given me a number of years service and I realise this problem may well just be down to age. However, I've recently replaced all the smaller ink cartridges (always used Canon ink) so would like to see if there's a way to fix the problem before abandoning the printer to the scrap heap.


All the colour cartridges were empty and I noticed when taking them out that there wasn't a light on the magenta slot. I thought nothing of it but there still wasn't a light when I put the new cartridge in. Until I tried to print I thought perhaps the light had just gone.


I put a different colour cartridge in the slot and the light came on and it was recognised, so not that.


I then tried all sorts of solutions I've seen here and elsewhere - switching off at the plug when switched on, pressing reset, cleaning the magenta chip, taking out the printer head and cleaning that, amongst them.


Finally I bought a new cartridge in the hope that the empty one had developed a chip fault, and the first new one I tried had just been faulty. Unlikely, I know. Of course, the magenta is still not being recognised and the error message is that there's nothing in the slot and I need to put a cartridge in.


I just want to know if there's a likely solution out there before I buy a new printer. Thanks very much for your time.






Product Expert
Product Expert



If the issue persists after the tank has been removed and reinstalled, troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Enter for a chance to win