Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra


After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.


Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Didn't work from my first go neither. Worked after I first removed the old version and then installed the new 4.0.5 version using the link.

Groan. I deleted all the old files and now nothing comes up. I'm done. Right now, I have to restore my iPad, since the last IOS update screwed it up. I may never do another OS update!

I've tried using Preview to scan as several here have suggested, but when I pull down the File menu, "Import from Scanner" is grayed out, ie unavailable. Do I need to add my peripheral somehow, so that Preview recognizes the device as a means of scanning?

Go to Systems Preference — Security & Privacy click Firewall, click the lock on the bottom left corner to make changes it will ask for you add ADM password. Click Firewall Options, Click the + sign to add a new application, browse to find Preview and/or Image Capture and add them to the list. Now you gave permission to your Mac to communicate with those programs. Restart and it should work.

I did add the "MP Navigator  EX 4.1" and "MP Navigator EX 4.1 Opener" programs to the firewall list. However, that was not enough to fix the issue. I still get the "MP Navigator EX quit unexpectedly" error message when I start scanning from the Canon Pixma MX882 front panel. Super annoying bug!


It seems that the bug is the following: when the MP Navigator EX 4.1 Opener is launched (following the printer's starting to contact the computer over the network), it crashes and displays the error message. When it crashes, both the  "MP Navigator  EX 4.1" and "MP Navigator EX 4.1 Opener" programs quit.







I had the same problem than you. My scanner (Canon MP620) didn't work anymore when I set up the last version of macOS (10.13 High Sierra). So I setup the last version of MP Navigator (v2.0.8 available at and now everything work again for me!

Does use of Preview or Image Capture support use of the Auto Document Feeder (ADF) or just single platen scans?

I've been able to use the ADF with Image Capture.


I'm having a problem with my Canon LiDE 110 stand alone scanner.  MP Navigator EX 4.0 stopped working AFTER I installed MacOS High Sierra.  Before that worked fine.  Any clues to get it to work or suggestions for new scanner software?

Attention everyone: the best solution to this upgrade-obsolescence problem that Canon has inflicted upon all of us is probably this:


Find an old laptop that's using a legacy version of MacOSX. Install MP Navigator and use it to operate your scanner. 


I have done so, and now that I can use my laptop to scan with my MX350, I'll have to remember never to upgrade it.


None of the proposed workarounds -- neither using Preview, nor installing MP Navigator 4.0.5. -- have worked for me.