Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG5520 scanner no longer connecting (and not scanning).


I've been using a PIXMA MG5520 to print and scan since April, 2014. Sometime in the past couple of weeks, it lost the ability to scan. I can still print, I just can't scan. I'm running Windows 10 Home, Version 1909, OS Build 18363.476.


When I try to use the Canon IJ Scan Utility to scan, I get the following message:


An error has occurred.

Turn the device off and then back on.

Scanner driver will be closed.




I turned the MG5520 off and back on, and tried again.


Same error.


I did a hard reset (with the printer on, I yanked the plug then plugged it back in), and tried again.


Same error.


Using Settings... Devices... Printers & Scanners on the PC, I removed the device, then from Device Manager I uninstalled the printer and deleted the drivers. I downloaded the most recent driver package from the Canon Web site and re-installed the drivers and software. As part of the installation (from the printer), I added the printer to my WiFi network and double-checked that the settings were correct. Setup... Device settings... LAN settings... Confirm LAN settings... WLAN setting list showed Connection: Active, SSID: [the correct and only available SSID], Communication mode: Infrastructure. I tried scanning again.


Same error.


Then I tried using the printer's controls to scan. I selected Scan, PC. The Select PC screen appeared, and the only choice available was "Local (USB)". Since the printer is not connected via USB, this was also a dead end.


I have double- and triple-checked my router and my security settings (I have Webroot installed). The settings have not been changed in months, and there is no error log relating to the scanner. I also tried deactivating my security software to see what would happen, but that didn't help: Same error.


What do I have to do to get scanning working again?




P.S. It would be physically impossible to connect this printer to its PC via USB, so that is not a solution in my case. Based on the error messages I've seen, I'm guessing that the problem involves a failure to communicate via WiFi, but WiFi really is the only workable option for me.


Product Expert
Product Expert

Hi larryc43230,


The 2,250,200 error is an indication that there is security software blocking communication from the scanner to your computer.


Also, once the drivers and software are reinstalled, your computer should be added to the "Scan to" screen on the printer when you attempt to scan.  Because it was not there, this is other evidence that security software is blocking communication.


Please temporarily disable any active security software and reinstall.  This can also be caused by expired software as well.  If you have expired security software on your computer, please make sure that it is disabled or uninstall it if you are not using it.


Once done, please reinstall.  When the installation is complete, attempt to scan using the IJ Scan Utility.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi, I disabled Windows Defender and uninstalled Malwarebytes. Still getting the same error message when scanning. Please advise next steps. Thanks

I was a PC network administrator before I retired. I'm aware of how security software can block activity and interfere with software installation. I completely disabled both my security software (WebRoot) and Windows Defender (including the firewall) while troubleshooting this issue, and when uninstalling and reinstalling the Canon software and drivers. The uninstalls and reinstalls appeared to succeed, with no error messages or warnings of any kind, but the result was the same: Scanning is still broken.


Regarding keeping my security software up to date, WebRoot automatically updates itself as needed. That's one reason I chose Webroot as my security software.


This is NOT a security software issue.



Product Expert
Product Expert



For testing purposes, try installing the Canon PRINT Inkjet/SELPHY app on an iOS or Android phone/tablet.  Are you able to scan with this app?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I already have the "Canon PRINT Inkjet/SELPHY" app installed on my Android (Samsung) phone, and I'm able to use the app to scan a document.


But that doesn't really answer any questions, other than establishing that the MG5520's scanning hardware and the Android app still work. This narrows it down to an issue with Windows, and my best guess is that a recent Windows Update (probably the update to Version 1909) has "broken" the Canon scanner software.


It does not by any means implicate security software. Several users, in several threads (including this one), have stated that deactivating security software when uninstalling, reinstalling, and/or using the Canon IJ Scan Utility has made no difference. Scanning is currently broken; at least with older printers using older (but the latest available) Canon drivers.



I just discovered that I can scan in documents from my MG5520 using the "Windows Fax and Scan" app that comes with Windows 10. And I still can't scan using the "Canon IJ Scan Utility".


Unfortunately, "Windows Fax and Scan" can create only graphics files (JPG, etc.), and cannot create PDF documents. This means that the Windows app won't solve my problem, since I really need to scan documents and create PDF files from them.


It seems to me, however, that this does establish that what is broken is the "Canon IJ Scan Utility". And it proves that the issue is NOT the WiFi connection between the printer/scanner and the PC, and the problem is very unlikely to have anything to do with security software or security settings.


If "Windows Fax and Scan" can scan in documents, why can't the "Canon IJ Scan Utility"?. 





Hi, larryc43230 and clawsonrbc.


As the MG5520 has been around for a long time, and operating systems have themselves been updated, you may both need to update the printer's firmware. Ensure the printer is on a network with internet access and use the directions found at this page in the Canon Knowledgebase.  Additionally, when controlling the scan at either a computer or mobile device , the printer will need to be on its home screen.  If the printer is set to any other screen, it may respond to attempts from a computer or mobile device to scan as "In Use".




Once the firmware has been updated, try the following steps:

  1. Remove the MG5520 from your list of available printers (Settings > Devices > Printers & Scanners > Canon MG5500 series Printer > Remove Device).

  2. Uninstall the printer's driver and (if it's installed) the Extended Survey Program. ("Settings > Apps" or "Settings > System > Apps & Features")

  3. Restart the computer.
    • Note: Restarting the computer after uninstalling clears lingering settings that can persist driver corruption.
  4. Reinstall the printer using the MG5500 series MP Driver, available at the MG5520 Drivers & Downloads page on the Canon U.S.A. website.

To answer your question, the Windows Fax and Scan is designed to work with the generic drivers that come preinstalled in Windows operating systems.  The IJ Scan Utility requires the Canon-produced drivers to communicate properly with a Canon printer, and to better process the image data.

Darius, thank you for trying to help, but I've already tried everything you suggested, more than once.


The printer is on my WiFi network, and has been since I purchased it several years ago.


One of the first things I did after discovering that I couldn't scan from the MG5520 was to check for firmware updates.


The printer reported that:


     Your firmware is the latest


     Update is not required.


When I performed the "Check current version" menu entry, the printer reported:


     Current version: 3.100


I just went through that process again, and got exactly the same result.


Before I created this thread, I downloaded the latest drivers from the Web page you suggested, but as far as I could determine they were exactly the same as were already installed. The file date and size were precisely the same as I already had in my software archive.


I completely uninstalled the printer drivers, restarted the PC, then installed the drivers again using the freshly-downloaded drivers. I went through this process thinking that, even though the driver package apparently hadn't changed, perhaps the installed drivers had somehow become corrupted.


After restarting the PC again, I tried scanning through the IJ Scan Utility and it failed in exactly the same way.


Since then, I've gone through the entire uninstall/reinstall process at least twice more, and the results haven't changed. I still can't scan using the IJ Scan Utility.


I've tried several times to scan with the printer at the Home screen, with the same result: Scanning from the IJ Scan Utility aborts with an error message. The message said nothing about the printer or scanner being "In Use", either on the PC or in the printer's display.


I can scan using the Android app (which results in a file on my phone which I then have to transfer to the PC), and I can scan through Windows Fax and Scan, which doesn't provide the option of creating a PDF file, which is what I need 90% of the time.



My security software is Webroot SecureAnywhere. As it turns out, their software was somehow blocking Canon's "IJ Scan Utility" from connecting with the scanning component of the printer, and there was no settings change I could make to resolve the issue from my end. I contacted Webroot, and they sent me a link to an application updater that succcessfully resolved the issue, at least in my case.


As far as I'm aware, as of this date Webroot is issuing this update only to those who request it. For any Canon printer/scanner users who also have Webroot as their security software provider, I suggest that you submit a help ticket regarding this issue. Webroot will hopefully respond with the update you need.


The version of Webroot SecureAnywhere installed on my PC after the update is v9.0.27.201. The updated version number might be different depending on which level of security protection you've purchased.


I hope this helps others with their scanning issues.