Showing results for 
Show  only  | Search instead for 
Did you mean: 

Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).


I'm getting a U052 error message on my Pixma MP610 printer.  It reads "The type of printhead is incorrect. Install the correct printhead."  I replaced an ink cartridge that was running low, but still get that message.  I've had the printer for some time and never got that kind of message before.



I also have the U052 (type of printhead incorrect on my Pixma MP610 printer.  It was working fine one day and the next it quit working.  At that time no error messages yet when I went to print someting a blank page would come out.  I let it sit a few days due to the fact that I was busy and then I turned it back on and all of a sudden I recieved the U052 message.  I am so furstrated 😞  Obviously from the other post on here and other boards replacing the print head is not a solution.  It also seems to happen with many other printers.  Boo to canon.


I just received this message on my MP610. I printed a page of 2, then the printer went dead..would not power up. let it sit overnight, and it powered back on, but now I get the U052 error message. Tried reseting the printhead, etc, but nothing works.


I have never used anything but genuine Canon cartridges, but this wasnt much help.


Any suggestions. If I need service, what are my options. I have several cartridges here, as I do a lot of printing. There are no printers available that use the same cartridges.




Along with many, I have the same recurring problem with my MP610.  One noteworthy difference (Canon support) is that it works fine on my desktop and laptop (Win7) and only creates the error with my wife's laptop (HP with Win7).  I've reinstalled the driver several times on her laptop and it works a few times but then comesback.  I have to reset the MP610 by turning off before I can use it with my pc's.  Definitely a frustrating issue for an otherwise nice unit.


After getting an answer from Canon Support to buy another printer head for $200, I decided to recycle the unit and buy another brand.  Very poor service.

My printer cost $170 I will not pay $200 for a new print head

Reseating the print head worked for me for about 5 pages of print, then the printer went dead. Since I have had several years of faithful service from my mp610, I looked for a canon multifunction to replace it with and settled on the mx922. Built in fax, wired and wireless networking, google cloud printing, I am very pleased with it so far

I gave up on mine a while back; couldn't get any kind of reset and as posted many times over here, Canon was of know help.  I looked at new multi-functions and it was a tie between a Canon MG7120 and an Epson.  I really liked the Epson but am a Canon fan (photography-wise) so I went with the MG7120.  To be brief, I hate it.  It's noisy, has a long start up process and an after printing ritual which includes slamming the outfeed door back open if you had shut it after printing.  I checked inside many times to see if there was packaging or something left behind.  The thing makes a lot of noise as it moves the print head back and forth (during startup and the after printing ritual). My MP610 was so much nicer.  Funny, I tried to do a review on the Canon site (after being invited to do so), however it was rejected because I mentioned Epson.


Will still check out Canon in the future and will continue to buy Canon photography eqiuipment, however, Epson has improved by leaps and bounds and is now a leader in photo and photo-quality printers so I'll likely go that route. (I dislike this one so much, I've considered giving it away or selling it for a few bucks and getting the Epson xxx.

("no help", sorry)

i have the same problem this morning it was working fine last night now the UO 52 error and i have removed inks and printer head and wiped it clean and still nothing


ou know what's silly: I had this error on the same printer before. I read somewhere online that cold causes this error. And truly, printer was left in a cold room both times. And the first (and second) time it happened, I find a solution online-you have to hold the right combination of buttons. I did that and it worked just fine. But the last time this error happened, I could not find, what is the combination. I think our printers can still work, if only canon wouldn't mind reveling their secret. I mean, it's still better for the busines, cos we'll be buying more of their ink's then, but certanly not new print head or defenetly not another canon printer.

click here to view the gallery