Showing results for 
Show  only  | Search instead for 
Did you mean: 

G7020 won't print black ink


All the ink levels are full. When I run a nozzle check, the black ink is completely absent. 

When I do a cleaning or deep cleaning, it stops just seconds into it and says Error 5200. So I turn off the printer and unplug it for more than 10 minutes. When I turn it back on and retry, same problem.

I've done multiple ink flushes- I did one ink flush for black ink only, but Error 5200 showed up again. I tried an ink flush for all the colors, and no error appeared, but I'm not sure the ink flush completed- it seemed like the printer was quiet and not doing much. After the ink flush that I did for all the colors, the black ink was still not working.

Thanks for any help!


Product Expert
Product Expert


If ink does not flow after the nozzle cleanings and ink flush, the printer would require service. 

If the printer is in it's 1 year warranty, I recommend reaching out to Canon support for your warranty options. You will need to register your Canon gear HERE to access additional support options.

If the printer is out of warranty, you would qualify for the Canon Upgrade program. This is for out of warranty units which have been diagnosed to require service or are incompatible with a new or upgraded system. This program allows you the opportunity to purchase a replacement product discounted from the list price. Free ground shipping is included with your purchase.

If you would like to take advantage of this offer, please call our Sales Department at (866) 443-8002 Mon-Sat, 9 AM to 9pm EST excluding holidays.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

click here to view the press release