Showing results for 
Search instead for 
Did you mean: 

G3010 - Can't install driver


First installation was successful, however I had to replace my hard drive and now the driver WILL NOT complete the installation. Can anyone help me please?



Good Morning.

We'd like to try and help.  Unfortunately, can't, won't or will not are not a helpful problem descriptions.  It doesn't tell us what you did, or what happened when you did it.


We know you have a G3010


What OS are you using?


What driver are you trying to install?


How is the printer connected?


What happenes?  Error messages?, etc.


Please provide as much detail as possible about the problem or challenge you are facing.  We can try to help from there.





Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Thanks so much for the offer to assist Rick - it's really appreciated.


So I recently had to get a new hard drive for my pc. When I first purchased the Canon 3411 printer I was able to plug it in, load the driver & was away. Since I got my pc back with its new hard drive the printer driver refuses to load.


I have Windows 10 on a 64 bit machine. The printer is connected with a USB cable (brand new since I thought that might be the problem), I tried the driver from the CD as well as downloaded


The set up from the unzipped driver package loads and runs. Has those 1, 2, 3 & 4 circled steps at the top of the process guide. 1) Downloads first 13 files or whatever its downloading 13 of. Then I can select Country and acknowledge the user license agreement(s). 2) I can de-activate the firewall. 3) I can select the type of connection ... I selected USB cable since I thought this to be easier and more secure. Then it starts to download .../91 MB. Then it installs MP drivers. Then it asks me to connect the USB cable as well as to turn the printer on. It says that its detected the printer. Then it says that this process may take some time!


From there it's just a hamster in its excercise wheel - turning and turning and turning until it bombs out and wants to start the setup process all over again.


Hope you can help.



Which printer do you have? 


Subject line says "G3010" (Canon India)

Model listed in the message body is "3411" (Canon Europe / South Africa)




Windows 10 Drivers G3010


Windows 10 Drivers G3411


Upon review, it appears that the installer is one in the same "win-g3010-1_0-n_mcd.exe" (18.4mb)


So it probably doesn't matter which you use.  The printer should not be connected until you are prompted.  The device should be connected directly to a USB port on the motherboard or laptop and not to a hub, etc. 


Assume you are installing under a user account with admin permissions?


3rd party antivirus software can also interfere.


Have you tried connecting the printer to another USB port during the detection phase?


If you have other USB devices connected (beside mouse or keyboard) disconnect them temporarily.


If you still experience problems, check if you have an existing USB port installed for the printer.  If so, remove it, restart the system and run set up again.  This can be created during a unsuccessful or failed installation attempt.  


Verify that an application exception for the Canon installer exists in the windows firewall  regardless of what the installer says it did, look for yourself and create if needed. 


Post your progress.



Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

G3010 canon

Canon G3010 india