cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enough of MX xxx printing blank pages

jdatx
Apprentice

Earlier this week my MX 892 starting to "print" blank pages. This printer is 18 months old and worked like a charm for those 18 months.

I did the multi-step procedure that is supposed to clean up the clogged head, to no avail. I then called support and got a nice tech who had not heard once of a similar problem. I'm surprised that this is the case given the number of peope who have posted similar issues on this forum.

 

This is my second Canon printer that fails for that reason. The reason I bought the MX892 18 months ago is because my MX850 started to print blank pages as well. Exact same sympton, exact same lack of solution or support from Canon.

 

It is simply unacceptable from a company like Canon to provide printers that are so unreliable over time.

I own multiple Canon DSLR and lenses and I'm expecting out of Canon than the experience that I have with their printer. I'm thinking about completely let go of Canon and go with other brands.

 

The printers does not give any error code at all, it just pretends that things are printed perfectly. This is unbelievable.

 

If there are enough cases, I'm looking at starting a class action for this.

2 REPLIES 2

kbpa
Apprentice

I just experienced the same problem.

 

My mx892 is less than a year old. I go south for 6 months. When I came back,  my mx892 printed about 2 pages and then started printing blank pages.

 

Of course, I went out and purchased all new cartrdiges. It printed 1 page and then started printing blank pages again.

 

I tried multiple nozzle cleanings, etc... I communicated online with Canon Support. We tried removing and reinstallling the print head. That did not work. Canon Fedex'd me a new print head. I just installed it. Everything seems to be working fine as I've printed about 10 pages so far with no isses. The problem of printing blank pages seems to have been resolved.

 

Thought I might want to share since I see multiple MX892 users who exerienced the same issue.

 

Good Luck,

 

Kevin

Curious if anyone has used generic ink? I need to know if this could be the problem?
Avatar
click here to view the gallery
Announcements